# CVE-2026-54178: Laravel Backpack CRUD: Arbitrary file deletion via attacker-controlled clear_<attr>[] in HasUploadFields::uploadMultipleFilesToDisk

> Authenticated users can delete arbitrary files on the server by manipulating upload field parameters, affecting Laravel Backpack CRUD users.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Sep 2026
- **Updated:** 16 Sep 2026
- **Also known as:** GHSA-8xjm-wqrp-2f25

## What is CVE-2026-54178?

CVE-2026-54178 is a high-severity path traversal vulnerability in Laravel-Backpack CRUD, published on 14 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

backpack/crud provides Create, Read, Update & Delete (CRUD) functions for Backpack, a collection of Laravel packages that help users build custom administration panels. Prior to 6.8.12 and 7.0.35, HasUploadFields::uploadMultipleFilesToDisk in src/app/Models/Traits/HasUploadFields.php trusts disk-relative paths from clear_<attribute>[] and passes them to Storage::disk()->delete without confirming that the paths are persisted on the current model record. An authenticated user with Update access to a CRUD using this mutator through src/app/Models/Traits/CrudTrait.php can delete another record's attachment, a shared asset, or another operational file on the configured disk by submitting its path. The newer MultipleFiles uploader is not affected because it intersects requested deletions with the record's persisted file list. This flaw does not permit reading the deleted files. The 5.x line remains affected through its final releases. This issue is fixed in versions 6.8.12 and 7.0.35.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key), CWE-285 (Improper Authorization), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-54178?

6 open source packages ship an affected version, including backpack/crud.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `backpack/crud` | Packagist | From 5.0.0 | None |
| `backpack/crud` | Packagist | From 5.0.0 | None |
| `backpack/crud` | Packagist | From 6.0.0 | 6.8.12 |
| `backpack/crud` | Packagist | From 6.0.0 | 6.8.12 |
| `backpack/crud` | Packagist | From 7.0.0 | 7.0.35 |
| `backpack/crud` | Packagist | From 7.0.0 | 7.0.35 |

## How do I fix CVE-2026-54178?

Upgrade backpack/crud to a fixed version for your release line: 6.8.12 or 7.0.35.

## Is CVE-2026-54178 being exploited?

There is no known exploitation of CVE-2026-54178 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54178 and fix it if it is affected.

What it is: CVE-2026-54178 is a high-severity path traversal vulnerability in Laravel-Backpack CRUD, published on 14 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-54178 in the wild and no public exploit code.

Affected packages and fixed versions:
- backpack/crud (Packagist): affected from 5.0.0; no fix listed
- backpack/crud (Packagist): affected from 5.0.0; no fix listed
- backpack/crud (Packagist): affected from 6.0.0; fixed in 6.8.12
- backpack/crud (Packagist): affected from 6.0.0; fixed in 6.8.12
- backpack/crud (Packagist): affected from 7.0.0; fixed in 7.0.35
- backpack/crud (Packagist): affected from 7.0.0; fixed in 7.0.35

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54178/ (Markdown: https://insights.sbomify.com/CVE-2026-54178/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54178
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54178
- OSV: https://osv.dev/vulnerability/CVE-2026-54178

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54178/
Summaries are generated and may contain mistakes; the official description above is the record.
