# CVE-2026-54183: Apache Airflow: Airflow Variables were not masked in the UI for authenticated users

> Authenticated users can view unmasked sensitive Airflow Variables in the UI due to incomplete masking logic for nested data structures.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Aug 2026
- **Updated:** 16 Sep 2026
- **Also known as:** BIT-airflow-2026-54183, CLEANSTART-2026-NZ97420, ECHO-be77-b78c-718d, GHSA-g4qj-5vxv-wggf, MINI-cp5v-9x27-w57r, MINI-jpvx-3633-mg94, PYSEC-2026-3705

## What is CVE-2026-54183?

CVE-2026-54183 is a medium-severity vulnerability in Apache Airflow, published on 12 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Apache Airflow's secrets masker hides values stored under sensitive key names when they are displayed in the UI. The masker's recursion-depth limit did not descend into values nested inside a list, tuple, or set beyond that limit, so an Airflow Variable holding such a deeply-nested value was shown unmasked in the Variables UI. The exposure is limited to the UI: any authenticated user who can see the Variable in the UI can already read its full value through the Variables REST API, so this does not disclose data the user could not otherwise obtain — the masking is a shoulder-surfing defense for the UI, not an access-control boundary.

This is an incomplete-fix follow-up to CVE-2026-42358, whose fix made only the dictionary walk unbounded; lists, tuples, and sets beyond the depth limit remained unmasked in the UI. Deployments that applied the CVE-2026-42358 fix should also upgrade to address this residual case. Upgrade to apache-airflow 3.3.1 or later.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-54183?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | All versions | 3.3.1 |
| `apache-airflow` | PyPI | All versions | 3.3.1 |
| `apache-airflow` | PyPI | All versions | 3.3.1 |
| `airflow` | Bitnami | All versions | 3.3.1 |

Products: Apache Airflow.

## How do I fix CVE-2026-54183?

Upgrade apache-airflow to 3.3.1 or later.

## Is CVE-2026-54183 being exploited?

There is no known exploitation of CVE-2026-54183 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54183 and fix it if it is affected.

What it is: CVE-2026-54183 is a medium-severity vulnerability in Apache Airflow, published on 12 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-54183 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected all versions; fixed in 3.3.1
- apache-airflow (PyPI): affected all versions; fixed in 3.3.1
- apache-airflow (PyPI): affected all versions; fixed in 3.3.1
- airflow (Bitnami): affected all versions; fixed in 3.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54183/ (Markdown: https://insights.sbomify.com/CVE-2026-54183/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54183
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54183
- OSV: https://osv.dev/vulnerability/CVE-2026-54183

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54183/
Summaries are generated and may contain mistakes; the official description above is the record.
