CVE-2026-54232 vLLM: Dependency Confusion Vulnerability in vLLM Dockerfile

High 8.8 Published Updated

Attackers can execute arbitrary code and steal data by registering a missing package on PyPI, exploiting dependency confusion in the vLLM Docker build process.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-54232?

CVE-2026-54232 is a high-severity vulnerability in Vllm Vllm, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

vLLM is an inference and serving engine for large language models (LLMs). Prior to 0.22.1, the vLLM Dockerfile is vulnerable to a dependency confusion attack through the flashinfer-jit-cache package. The package is installed from a custom index (flashinfer.ai/whl/) using --extra-index-url, but the package name was not registered on PyPI, and UV_INDEX_STRATEGY="unsafe-best-match" is set globally. An attacker who registers flashinfer-jit-cache on PyPI with version 0.6.11.post2 can execute arbitrary code as root during the Docker build and backdoor every resulting container image, enabling exfiltration of all user prompts, API credentials, and model data from production vLLM deployments This vulnerability is fixed in 0.22.1.

Weakness: CWE-427

Which versions are affected by CVE-2026-54232?

1 open source package ship an affected version, including vllm. It affects 1 product.

PackageAffectedFixed in
vllm PyPIAll versions0.22.1

Products include Vllm Vllm.

How do I fix CVE-2026-54232?

Upgrade vllm to 0.22.1 or later.

Is CVE-2026-54232 being exploited?

There is no known exploitation of CVE-2026-54232 in the wild and no public exploit code.

All Vllm Vllm vulnerabilities

Sources

Also known as GHSA-jrf6-vqxq-pjv2, MINI-cvf6-43v8-9xvp, MINI-wpcq-p45h-gv8h, MINI-x97c-5xgp-qww8, PYSEC-2026-227.

Is CVE-2026-54232 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free