# CVE-2026-54232: vLLM: Dependency Confusion Vulnerability in vLLM Dockerfile

> Attackers can execute arbitrary code and steal data by registering a missing package on PyPI, exploiting dependency confusion in the vLLM Docker build process.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Jun 2026
- **Updated:** 23 Jun 2026
- **Also known as:** GHSA-jrf6-vqxq-pjv2, MINI-cvf6-43v8-9xvp, MINI-wpcq-p45h-gv8h, MINI-x97c-5xgp-qww8, PYSEC-2026-227

## What is CVE-2026-54232?

CVE-2026-54232 is a high-severity vulnerability in Vllm Vllm, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

vLLM is an inference and serving engine for large language models (LLMs). Prior to 0.22.1, the vLLM Dockerfile is vulnerable to a dependency confusion attack through the flashinfer-jit-cache package. The package is installed from a custom index (flashinfer.ai/whl/) using --extra-index-url, but the package name was not registered on PyPI, and UV_INDEX_STRATEGY="unsafe-best-match" is set globally. An attacker who registers flashinfer-jit-cache on PyPI with version 0.6.11.post2 can execute arbitrary code as root during the Docker build and backdoor every resulting container image, enabling exfiltration of all user prompts, API credentials, and model data from production vLLM deployments This vulnerability is fixed in 0.22.1.

Weakness: CWE-427 (Uncontrolled Search Path Element)

## Which versions are affected by CVE-2026-54232?

1 open source package ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | All versions | 0.22.1 |

Products: Vllm Vllm.

## How do I fix CVE-2026-54232?

Upgrade vllm to 0.22.1 or later.

## Is CVE-2026-54232 being exploited?

There is no known exploitation of CVE-2026-54232 in the wild and no public exploit code.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54232 and fix it if it is affected.

What it is: CVE-2026-54232 is a high-severity vulnerability in Vllm Vllm, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-54232 in the wild and no public exploit code.

Affected packages and fixed versions:
- vllm (PyPI): affected all versions; fixed in 0.22.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54232/ (Markdown: https://insights.sbomify.com/CVE-2026-54232/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54232
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54232
- OSV: https://osv.dev/vulnerability/CVE-2026-54232

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54232/
Summaries are generated and may contain mistakes; the official description above is the record.
