CVE-2026-54233 vLLM: OOM Denial of Service via Audio Decompression Bomb

Medium 6.5 Published Updated

Attackers can cause denial of service in vLLM by uploading small audio files that expand into massive memory usage during decoding.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-54233?

CVE-2026-54233 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 22 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

vLLM is an inference and serving engine for large language models (LLMs). Prior to 0.23.1rc0, vLLM's /v1/audio/transcriptions endpoint limits compressed upload size but not decoded PCM output. A 25MB OPUS file expands to ~14.9GB of float32 PCM at decode time. This vulnerability is fixed in 0.23.1rc0.

Weakness: CWE-409

Which versions are affected by CVE-2026-54233?

3 open source packages ship an affected version, including vllm. It affects 1 product.

PackageAffectedFixed in
vllm PyPIAll versions to 0.23.0None
vllm PyPIAll versions0.24.0
vllm PyPIAll versions0.24.0

Products include Vllm Vllm.

How do I fix CVE-2026-54233?

Upgrade vllm to 0.24.0 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-54233 being exploited?

There is no known exploitation of CVE-2026-54233 in the wild and no public exploit code.

All Vllm Vllm vulnerabilities

Sources

Also known as GHSA-6pr9-rp53-2pmc, MINI-77wq-q45h-v222, MINI-ffxm-53gj-7fj8, MINI-v9fq-hhgm-m8m6, PYSEC-2026-3404.

Is CVE-2026-54233 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free