CVE-2026-54234 vLLM: Remote DoS in vLLM via Invalid Recovered Token Reinjection

High 7.5 Published Updated

Remote attackers can crash the vLLM engine worker via crafted speculative decoding requests, causing service-wide denial of service.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-54234?

CVE-2026-54234 is a high-severity denial of service vulnerability in Vllm Vllm, published on 6 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

vLLM is a high-throughput and memory-efficient inference and serving engine for LLMs. Prior to 0.24.0, a frontend-legal multi-request speculative decoding workload can cause the rejection sampler to produce a recovered token equal to the model vocabulary size boundary value, which is then converted to negative one when the engine selects the next live token for a request and is written back into the drafter's input ids; that out-of-vocabulary value is later consumed by the model's embedding and attention path and crashes the engine worker with a GPU device-side assertion. The same triggering request sequence is reachable through the public gRPC Generate and Abort endpoints, so a remote client that can send generation requests can crash the shared engine worker, aborting concurrent requests and causing a service-wide denial of service for other clients of the deployment until the worker is restarted. This issue is fixed in version 0.24.0.

Weakness: CWE-20, CWE-1284

Which versions are affected by CVE-2026-54234?

3 open source packages ship an affected version, including vllm. It affects 1 product.

PackageAffectedFixed in
vllm PyPIFrom 0.17.10.24.0
vllm PyPIFrom 0.17.10.24.0
vllm PyPIFrom 0.17.10.24.0

Products include Vllm Vllm.

How do I fix CVE-2026-54234?

Upgrade vllm to 0.24.0 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-54234 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54234 exists.

All Vllm Vllm vulnerabilities

Sources

Also known as GHSA-8wr5-jm2h-8r4f, MINI-6x45-vhwg-79vf, MINI-8m84-v4q3-ch44, MINI-mvv8-gf6f-7vmm, PYSEC-2026-3542.

Is CVE-2026-54234 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free