{"answers":{"affected":"3 open source packages ship an affected version, including vllm. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54234 exists.","fix":"Upgrade vllm to 0.24.0 or later.","what":"CVE-2026-54234 is a high-severity denial of service vulnerability in Vllm Vllm, published on 6 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-54234 and fix it if it is affected.\n\nWhat it is: CVE-2026-54234 is a high-severity denial of service vulnerability in Vllm Vllm, published on 6 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54234 exists.\n\nAffected packages and fixed versions:\n- vllm (PyPI): affected from 0.17.1; fixed in 0.24.0\n- vllm (PyPI): affected from 0.17.1; fixed in 0.24.0\n- vllm (PyPI): affected from 0.17.1; fixed in 0.24.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-54234/ (Markdown: https://insights.sbomify.com/CVE-2026-54234/index.md)","id":"CVE-2026-54234","markdown":"https://insights.sbomify.com/CVE-2026-54234/index.md","name":"CVE-2026-54234","record":{"aliases":["GHSA-8wr5-jm2h-8r4f","MINI-6x45-vhwg-79vf","MINI-8m84-v4q3-ch44","MINI-mvv8-gf6f-7vmm","PYSEC-2026-3542"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"LLM inference engine","requires_auth":"none","summary":"Remote attackers can crash the vLLM engine worker via crafted speculative decoding requests, causing service-wide denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"vllm","vendor":"vllm"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"},{"id":"CWE-1284","name":"Improper Validation of Specified Quantity in Input"}],"description":"vLLM is a high-throughput and memory-efficient inference and serving engine for LLMs. Prior to 0.24.0, a frontend-legal multi-request speculative decoding workload can cause the rejection sampler to produce a recovered token equal to the model vocabulary size boundary value, which is then converted to negative one when the engine selects the next live token for a request and is written back into the drafter's input ids; that out-of-vocabulary value is later consumed by the model's embedding and attention path and crashes the engine worker with a GPU device-side assertion. The same triggering request sequence is reachable through the public gRPC Generate and Abort endpoints, so a remote client that can send generation requests can crash the shared engine worker, aborting concurrent requests and causing a service-wide denial of service for other clients of the deployment until the worker is restarted. This issue is fixed in version 0.24.0.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"vLLM: Remote DoS in vLLM via Invalid Recovered Token Reinjection","id":"CVE-2026-54234","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"vllm:vllm","products":["vllm:vllm"],"type":"denial_of_service","year":"2026"},"n_packages":3,"n_references":3,"next":{"headline":"vLLM: temperature=NaN and temperature=Infinity bypass validation and propagate to GPU kernels","id":"CVE-2026-54235"},"packages":[{"ecosystem":"PyPI","fixed":["0.24.0"],"introduced":["0.17.1"],"last_affected":[],"package":"vllm","purl":null,"source":"GHSA-8wr5-jm2h-8r4f"},{"ecosystem":"PyPI","fixed":["0.24.0"],"introduced":["0.17.1"],"last_affected":[],"package":"vllm","purl":"pkg:pypi/vllm","source":"GHSA-8wr5-jm2h-8r4f"},{"ecosystem":"PyPI","fixed":["0.24.0"],"introduced":["0.17.1"],"last_affected":[],"package":"vllm","purl":"pkg:pypi/vllm","source":"PYSEC-2026-3542"}],"prev":{"headline":"vLLM: OOM Denial of Service via Audio Decompression Bomb","id":"CVE-2026-54233"},"products":["vllm"],"published":"2026-07-06","related":[{"cvss_score":10,"headline":"vLLM Vulnerable to Remote Code Execution via Mooncake Integration","id":"CVE-2025-32444","kev_date_added":null,"published":"2025-04-30"},{"cvss_score":9.8,"headline":"vLLM leaks a heap address when PIL throws an error","id":"CVE-2026-22778","kev_date_added":null,"published":"2026-02-02"},{"cvss_score":9.8,"headline":"vLLM Allows Remote Code Execution via PyNcclPipe Communication Service","id":"CVE-2025-47277","kev_date_added":null,"published":"2025-05-20"},{"cvss_score":9.8,"headline":"Remote Code Execution in vllm-project/vllm","id":"CVE-2024-11041","kev_date_added":null,"published":"2025-03-20"},{"cvss_score":9.1,"headline":"vLLM: OpenAI auth bypass","id":"CVE-2026-48746","kev_date_added":null,"published":"2026-06-22"},{"cvss_score":9.1,"headline":"vLLM Allows Remote Code Execution via Mooncake Integration","id":"CVE-2025-29783","kev_date_added":null,"published":"2025-03-19"},{"cvss_score":8.8,"headline":"vLLM 0.9.2 before 0.24.0 SSRF via X-Request-Id in P2pNcclConnector","id":"CVE-2026-116176","kev_date_added":null,"published":"2026-10-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-07","vendors":["vllm-project"]},"summary":"Remote attackers can crash the vLLM engine worker via crafted speculative decoding requests, causing service-wide denial of service.","url":"https://insights.sbomify.com/CVE-2026-54234/"}