# CVE-2026-54234: vLLM: Remote DoS in vLLM via Invalid Recovered Token Reinjection

> Remote attackers can crash the vLLM engine worker via crafted speculative decoding requests, causing service-wide denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jul 2026
- **Updated:** 7 Jul 2026
- **Also known as:** GHSA-8wr5-jm2h-8r4f, MINI-6x45-vhwg-79vf, MINI-8m84-v4q3-ch44, MINI-mvv8-gf6f-7vmm, PYSEC-2026-3542

## What is CVE-2026-54234?

CVE-2026-54234 is a high-severity denial of service vulnerability in Vllm Vllm, published on 6 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

vLLM is a high-throughput and memory-efficient inference and serving engine for LLMs. Prior to 0.24.0, a frontend-legal multi-request speculative decoding workload can cause the rejection sampler to produce a recovered token equal to the model vocabulary size boundary value, which is then converted to negative one when the engine selects the next live token for a request and is written back into the drafter's input ids; that out-of-vocabulary value is later consumed by the model's embedding and attention path and crashes the engine worker with a GPU device-side assertion. The same triggering request sequence is reachable through the public gRPC Generate and Abort endpoints, so a remote client that can send generation requests can crash the shared engine worker, aborting concurrent requests and causing a service-wide denial of service for other clients of the deployment until the worker is restarted. This issue is fixed in version 0.24.0.

Weakness: CWE-20 (Improper Input Validation), CWE-1284 (Improper Validation of Specified Quantity in Input)

## Which versions are affected by CVE-2026-54234?

3 open source packages ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | From 0.17.1 | 0.24.0 |
| `vllm` | PyPI | From 0.17.1 | 0.24.0 |
| `vllm` | PyPI | From 0.17.1 | 0.24.0 |

Products: Vllm Vllm.

## How do I fix CVE-2026-54234?

Upgrade vllm to 0.24.0 or later.

## Is CVE-2026-54234 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54234 exists.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54234 and fix it if it is affected.

What it is: CVE-2026-54234 is a high-severity denial of service vulnerability in Vllm Vllm, published on 6 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54234 exists.

Affected packages and fixed versions:
- vllm (PyPI): affected from 0.17.1; fixed in 0.24.0
- vllm (PyPI): affected from 0.17.1; fixed in 0.24.0
- vllm (PyPI): affected from 0.17.1; fixed in 0.24.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54234/ (Markdown: https://insights.sbomify.com/CVE-2026-54234/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54234
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54234
- OSV: https://osv.dev/vulnerability/CVE-2026-54234

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54234/
Summaries are generated and may contain mistakes; the official description above is the record.
