CVE-2026-54235 vLLM: temperature=NaN and temperature=Infinity bypass validation and propagate to GPU kernels

Medium 6.9 Published Updated

Attackers can crash vLLM inference workers by sending NaN or Infinity temperature values that bypass validation checks.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-54235?

CVE-2026-54235 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

vLLM is an inference and serving engine for large language models (LLMs). Prior to 0.23.1rc0, ll temperature validation gates use comparison operators (<, >), which silently evaluate to False for NaN and for positive Infinity in Python's IEEE 754 float semantics. Both values pass every guard and propagate to GPU sampling kernels, where they produce undefined behavior or CUDA errors that can crash the inference worker. This vulnerability is fixed in 0.23.1rc0.

Weakness: CWE-1287

Which versions are affected by CVE-2026-54235?

3 open source packages ship an affected version, including vllm. It affects 1 product.

PackageAffectedFixed in
vllm PyPIAll versions to 0.23.0None
vllm PyPIFrom 0.8.50.24.0
vllm PyPIFrom 0.8.50.24.0

Products include Vllm Vllm.

How do I fix CVE-2026-54235?

Upgrade vllm to 0.24.0 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-54235 being exploited?

There is no known exploitation of CVE-2026-54235 in the wild and no public exploit code.

All Vllm Vllm vulnerabilities

Sources

Also known as GHSA-7h4p-rffg-7823, MINI-gccg-j4m6-q6q8, MINI-phh3-wp58-xh84, MINI-vfph-p7m2-65jf, PYSEC-2026-3405.

Is CVE-2026-54235 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free