# CVE-2026-54235: vLLM: temperature=NaN and temperature=Infinity bypass validation and propagate to GPU kernels

> Attackers can crash vLLM inference workers by sending NaN or Infinity temperature values that bypass validation checks.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jun 2026
- **Updated:** 23 Jun 2026
- **Also known as:** GHSA-7h4p-rffg-7823, MINI-gccg-j4m6-q6q8, MINI-phh3-wp58-xh84, MINI-vfph-p7m2-65jf, PYSEC-2026-3405

## What is CVE-2026-54235?

CVE-2026-54235 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

vLLM is an inference and serving engine for large language models (LLMs). Prior to 0.23.1rc0, ll temperature validation gates use comparison operators (<, >), which silently evaluate to False for NaN and for positive Infinity in Python's IEEE 754 float semantics. Both values pass every guard and propagate to GPU sampling kernels, where they produce undefined behavior or CUDA errors that can crash the inference worker. This vulnerability is fixed in 0.23.1rc0.

Weakness: CWE-1287 (Improper Validation of Specified Type of Input)

## Which versions are affected by CVE-2026-54235?

3 open source packages ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | All versions to 0.23.0 | None |
| `vllm` | PyPI | From 0.8.5 | 0.24.0 |
| `vllm` | PyPI | From 0.8.5 | 0.24.0 |

Products: Vllm Vllm.

## How do I fix CVE-2026-54235?

Upgrade vllm to 0.24.0 or later.

## Is CVE-2026-54235 being exploited?

There is no known exploitation of CVE-2026-54235 in the wild and no public exploit code.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54235 and fix it if it is affected.

What it is: CVE-2026-54235 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-54235 in the wild and no public exploit code.

Affected packages and fixed versions:
- vllm (PyPI): affected all versions up to 0.23.0; no fix listed
- vllm (PyPI): affected from 0.8.5; fixed in 0.24.0
- vllm (PyPI): affected from 0.8.5; fixed in 0.24.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54235/ (Markdown: https://insights.sbomify.com/CVE-2026-54235/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54235
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54235
- OSV: https://osv.dev/vulnerability/CVE-2026-54235

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54235/
Summaries are generated and may contain mistakes; the official description above is the record.
