{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-54239 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-54239 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-54239 is a high-severity authentication bypass vulnerability in wpengine faustjs, published on 17 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-54239 and fix it if it is affected.\n\nWhat it is: CVE-2026-54239 is a high-severity authentication bypass vulnerability in wpengine faustjs, published on 17 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-54239 in the wild and no public exploit code.\n\nAffected product: wpengine faustjs. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-54239/ (Markdown: https://insights.sbomify.com/CVE-2026-54239/index.md)","id":"CVE-2026-54239","markdown":"https://insights.sbomify.com/CVE-2026-54239/index.md","name":"CVE-2026-54239","record":{"aliases":["GHSA-q6pm-r77q-qcv3"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["privilege_escalation","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"low_privilege","summary":"A logged-in non-admin can modify the initialization vector to forge an administrator token, gaining full site control and code execution.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-639","name":"Authorization Bypass Through User-Controlled Key"},{"id":"CWE-345","name":"Insufficient Verification of Data Authenticity"}],"description":"Faust.js is a headless WordPress toolkit. Prior to 1.8.11, the FaustWP WordPress plugin authenticates only the ciphertext in its token envelope and excludes the 16-byte initialization vector from the HMAC in WPE\\FaustWP\\Auth\\encrypt() and WPE\\FaustWP\\Auth\\decrypt() in plugins/faustwp/includes/auth/functions.php. A logged-in non-administrator who obtains an authorization code from GET /generate can modify the unauthenticated initialization vector so that CBC decryption changes the token type and user identifier while the HMAC remains valid. This can produce an access token for an Administrator and permit full WordPress REST API access, administrator-account creation, plugin installation, and arbitrary code execution. This issue is fixed in repository version 1.8.11.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"FaustWP — Authentication Bypass via Initialization Vector Modification in Token Envelope","id":"CVE-2026-54239","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"auth_bypass","year":"2026"},"n_packages":0,"n_references":3,"next":{"headline":"libde265: Pixel accessor signed integer overflow causes heap OOB read/write","id":"CVE-2026-54240"},"packages":[],"prev":{"headline":"Supabase Realtime: Expired JWTs with string exp are accepted by REST broadcast authorization","id":"CVE-2026-54238"},"products":["faustjs"],"published":"2026-09-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-18","vendors":["wpengine"]},"summary":"A logged-in non-admin can modify the initialization vector to forge an administrator token, gaining full site control and code execution.","url":"https://insights.sbomify.com/CVE-2026-54239/"}