# CVE-2026-54239: FaustWP — Authentication Bypass via Initialization Vector Modification in Token Envelope

> A logged-in non-admin can modify the initialization vector to forge an administrator token, gaining full site control and code execution.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 17 Sep 2026
- **Updated:** 18 Sep 2026
- **Also known as:** GHSA-q6pm-r77q-qcv3

## What is CVE-2026-54239?

CVE-2026-54239 is a high-severity authentication bypass vulnerability in wpengine faustjs, published on 17 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Faust.js is a headless WordPress toolkit. Prior to 1.8.11, the FaustWP WordPress plugin authenticates only the ciphertext in its token envelope and excludes the 16-byte initialization vector from the HMAC in WPE\FaustWP\Auth\encrypt() and WPE\FaustWP\Auth\decrypt() in plugins/faustwp/includes/auth/functions.php. A logged-in non-administrator who obtains an authorization code from GET /generate can modify the unauthenticated initialization vector so that CBC decryption changes the token type and user identifier while the HMAC remains valid. This can produce an access token for an Administrator and permit full WordPress REST API access, administrator-account creation, plugin installation, and arbitrary code execution. This issue is fixed in repository version 1.8.11.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key), CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2026-54239?


## How do I fix CVE-2026-54239?

No fix has been published for CVE-2026-54239 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-54239 being exploited?

There is no known exploitation of CVE-2026-54239 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54239 and fix it if it is affected.

What it is: CVE-2026-54239 is a high-severity authentication bypass vulnerability in wpengine faustjs, published on 17 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-54239 in the wild and no public exploit code.

Affected product: wpengine faustjs. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54239/ (Markdown: https://insights.sbomify.com/CVE-2026-54239/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54239
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54239
- OSV: https://osv.dev/vulnerability/CVE-2026-54239

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54239/
Summaries are generated and may contain mistakes; the official description above is the record.
