# CVE-2026-54257: Electron: Buffer performs incorrect byte length calculations resulting in heap buffer under/overflow

> Incorrect byte length calculations in Electron's Buffer API can cause heap buffer overflows, leading to application crashes or potential code execution.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jun 2026
- **Updated:** 23 Jun 2026
- **Also known as:** GHSA-q6m5-f73j-m9mc

## What is CVE-2026-54257?

CVE-2026-54257 is a critical memory corruption vulnerability in electron, published on 23 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Electron is a framework for writing cross-platform desktop applications using JavaScript, HTML and CSS. From 42.3.1 until 42.3.3, Buffer performs incorrect byte length calculations resulting in heap buffer under/overflow. Most apps will crash and some may perform incorrect buffer allocations in the Node.js Buffer API resulting in unexpected truncation or allocation. This vulnerability is fixed in 42.3.3.

Weakness: CWE-120 (Buffer Copy without Checking Size of Input)

## Which versions are affected by CVE-2026-54257?

2 open source packages ship an affected version, including electron.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `electron` | npm | From 42.3.1 | 42.3.3 |
| `electron` | npm | From 42.3.1 | 42.3.3 |

## How do I fix CVE-2026-54257?

Upgrade electron to 42.3.3 or later.

## Is CVE-2026-54257 being exploited?

There is no known exploitation of CVE-2026-54257 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54257 and fix it if it is affected.

What it is: CVE-2026-54257 is a critical memory corruption vulnerability in electron, published on 23 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-54257 in the wild and no public exploit code.

Affected packages and fixed versions:
- electron (npm): affected from 42.3.1; fixed in 42.3.3
- electron (npm): affected from 42.3.1; fixed in 42.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54257/ (Markdown: https://insights.sbomify.com/CVE-2026-54257/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54257
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54257
- OSV: https://osv.dev/vulnerability/CVE-2026-54257

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54257/
Summaries are generated and may contain mistakes; the official description above is the record.
