CVE-2026-54263 Wagtail: Reflected XSS in dynamic image URL generator view
A reflected XSS vulnerability in the Wagtail admin interface allows low-privilege editors to execute scripts in the context of higher-privilege users.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-54263?
CVE-2026-54263 is a high-severity cross-site scripting vulnerability in wagtail, published on 1 Jul 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Wagtail is an open source content management system built on Django. In versions prior to 7.0.8, 7.3.3 and 7.4.2, reflected cross-site scripting (XSS) vulnerability exists on the dynamic image URL generator view within the Wagtail admin interface. A user with a limited-permission editor account for the Wagtail admin could craft a URL that, when viewed by a user with higher privileges, could perform actions with that user's credentials. The vulnerability is present for all sites, even if they do not enable the dynamic image serve view. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin. This issue has been fixed in versions 7.0.8, 7.3.3, and 7.4.2.
Weakness: CWE-79
Which versions are affected by CVE-2026-54263?
5 open source packages ship an affected version, including wagtail. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
wagtail PyPI | From 7.3 | 7.3.3, 7.4.2 |
wagtail PyPI | From 7.3 | 7.3.3 |
wagtail PyPI | From 7.3 | 7.3.3 |
wagtail PyPI | From 7.4 | 7.4.2 |
wagtail PyPI | From 7.4 | 7.4.2 |
Products include Torchbox Wagtail.
How do I fix CVE-2026-54263?
Upgrade wagtail to a fixed version for your release line: 7.3.3 or 7.4.2.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-54263 being exploited?
There is no known exploitation of CVE-2026-54263 in the wild and no public exploit code.
Other vulnerabilities in wagtail
- CVE-2026-54261 Wagtail: Improper permission handling in image preview
- CVE-2026-44197 Wagtail: Improper permission handling when comparing revisions
- CVE-2026-44199 Wagtail: Improper permission handling when deleting form submissions
- CVE-2026-44200 Wagtail: Improper permission handling when copying pages
- CVE-2024-39317 Wagtail regular expression denial-of-service via search query parsing
Sources
Also known as GHSA-23m2-mghx-vqmf, PYSEC-2026-616.