{"answers":{"affected":"5 open source packages ship an affected version, including wagtail. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-54263 in the wild and no public exploit code.","fix":"Upgrade wagtail to a fixed version for your release line: 7.3.3 or 7.4.2.","what":"CVE-2026-54263 is a high-severity cross-site scripting vulnerability in wagtail, published on 1 Jul 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-54263 and fix it if it is affected.\n\nWhat it is: CVE-2026-54263 is a high-severity cross-site scripting vulnerability in wagtail, published on 1 Jul 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-54263 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- wagtail (PyPI): affected from 7.3; fixed in 7.3.3, 7.4.2\n- wagtail (PyPI): affected from 7.3; fixed in 7.3.3\n- wagtail (PyPI): affected from 7.3; fixed in 7.3.3\n- wagtail (PyPI): affected from 7.4; fixed in 7.4.2\n- wagtail (PyPI): affected from 7.4; fixed in 7.4.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-54263/ (Markdown: https://insights.sbomify.com/CVE-2026-54263/index.md)","id":"CVE-2026-54263","markdown":"https://insights.sbomify.com/CVE-2026-54263/index.md","name":"CVE-2026-54263","record":{"aliases":["GHSA-23m2-mghx-vqmf","PYSEC-2026-616"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["account_takeover","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Wagtail CMS","requires_auth":"low_privilege","summary":"A reflected XSS vulnerability in the Wagtail admin interface allows low-privilege editors to execute scripts in the context of higher-privilege users.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"wagtail","vendor":"torchbox"}],"cvss":{"score":7.3,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Wagtail is an open source content management system built on Django. In versions prior to 7.0.8, 7.3.3 and 7.4.2, reflected cross-site scripting (XSS) vulnerability exists on the dynamic image URL generator view within the Wagtail admin interface. A user with a limited-permission editor account for the Wagtail admin could craft a URL that, when viewed by a user with higher privileges, could perform actions with that user's credentials. The vulnerability is present for all sites, even if they do not enable the dynamic image serve view. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin. This issue has been fixed in versions 7.0.8, 7.3.3, and 7.4.2.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Wagtail: Reflected XSS in dynamic image URL generator view","id":"CVE-2026-54263","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":5,"n_references":1,"next":{"headline":"Angular: Sensitive Header Leakage on Cross-Origin Redirects in Angular Service Worker","id":"CVE-2026-54264"},"packages":[{"ecosystem":"PyPI","fixed":["7.3.3","7.4.2"],"introduced":["7.3","7.4"],"last_affected":[],"package":"wagtail","purl":"pkg:pypi/wagtail","source":"PYSEC-2026-616"},{"ecosystem":"PyPI","fixed":["7.3.3"],"introduced":["7.3"],"last_affected":[],"package":"wagtail","purl":null,"source":"GHSA-23m2-mghx-vqmf"},{"ecosystem":"PyPI","fixed":["7.3.3"],"introduced":["7.3"],"last_affected":[],"package":"wagtail","purl":"pkg:pypi/wagtail","source":"GHSA-23m2-mghx-vqmf"},{"ecosystem":"PyPI","fixed":["7.4.2"],"introduced":["7.4"],"last_affected":[],"package":"wagtail","purl":null,"source":"GHSA-23m2-mghx-vqmf"},{"ecosystem":"PyPI","fixed":["7.4.2"],"introduced":["7.4"],"last_affected":[],"package":"wagtail","purl":"pkg:pypi/wagtail","source":"GHSA-23m2-mghx-vqmf"}],"prev":{"headline":"Wagtail: Pages translations can be created without page permissions when using simple_translation","id":"CVE-2026-54262"},"products":["wagtail"],"published":"2026-07-01","related":[{"cvss_score":6.5,"headline":"Wagtail: Improper permission handling in image preview","id":"CVE-2026-54261","kev_date_added":null,"published":"2026-07-01"},{"cvss_score":6.5,"headline":"Wagtail: Improper permission handling when comparing revisions","id":"CVE-2026-44197","kev_date_added":null,"published":"2026-05-11"},{"cvss_score":6.5,"headline":"Wagtail: Improper permission handling when deleting form submissions","id":"CVE-2026-44199","kev_date_added":null,"published":"2026-05-11"},{"cvss_score":6.5,"headline":"Wagtail: Improper permission handling when copying pages","id":"CVE-2026-44200","kev_date_added":null,"published":"2026-05-11"},{"cvss_score":6.5,"headline":"Wagtail regular expression denial-of-service via search query parsing","id":"CVE-2024-39317","kev_date_added":null,"published":"2024-07-11"},{"cvss_score":6.4,"headline":"Wagtail vulnerable to stored Cross-site Scripting attack via ModelAdmin views","id":"CVE-2023-28836","kev_date_added":null,"published":"2023-04-03"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-06","vendors":["wagtail"]},"summary":"A reflected XSS vulnerability in the Wagtail admin interface allows low-privilege editors to execute scripts in the context of higher-privilege users.","url":"https://insights.sbomify.com/CVE-2026-54263/"}