# CVE-2026-54263: Wagtail: Reflected XSS in dynamic image URL generator view

> A reflected XSS vulnerability in the Wagtail admin interface allows low-privilege editors to execute scripts in the context of higher-privilege users.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Jul 2026
- **Updated:** 6 Jul 2026
- **Also known as:** GHSA-23m2-mghx-vqmf, PYSEC-2026-616

## What is CVE-2026-54263?

CVE-2026-54263 is a high-severity cross-site scripting vulnerability in wagtail, published on 1 Jul 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Wagtail is an open source content management system built on Django. In versions prior to 7.0.8, 7.3.3 and 7.4.2, reflected cross-site scripting (XSS) vulnerability exists on the dynamic image URL generator view within the Wagtail admin interface. A user with a limited-permission editor account for the Wagtail admin could craft a URL that, when viewed by a user with higher privileges, could perform actions with that user's credentials. The vulnerability is present for all sites, even if they do not enable the dynamic image serve view. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin. This issue has been fixed in versions 7.0.8, 7.3.3, and 7.4.2.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-54263?

5 open source packages ship an affected version, including wagtail. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wagtail` | PyPI | From 7.3 | 7.3.3, 7.4.2 |
| `wagtail` | PyPI | From 7.3 | 7.3.3 |
| `wagtail` | PyPI | From 7.3 | 7.3.3 |
| `wagtail` | PyPI | From 7.4 | 7.4.2 |
| `wagtail` | PyPI | From 7.4 | 7.4.2 |

Products: Torchbox Wagtail.

## How do I fix CVE-2026-54263?

Upgrade wagtail to a fixed version for your release line: 7.3.3 or 7.4.2.

## Is CVE-2026-54263 being exploited?

There is no known exploitation of CVE-2026-54263 in the wild and no public exploit code.

## Other vulnerabilities in wagtail

- [CVE-2026-54261](https://insights.sbomify.com/CVE-2026-54261/): Wagtail: Improper permission handling in image preview (medium 6.5)
- [CVE-2026-44197](https://insights.sbomify.com/CVE-2026-44197/): Wagtail: Improper permission handling when comparing revisions (medium 6.5)
- [CVE-2026-44199](https://insights.sbomify.com/CVE-2026-44199/): Wagtail: Improper permission handling when deleting form submissions (medium 6.5)
- [CVE-2026-44200](https://insights.sbomify.com/CVE-2026-44200/): Wagtail: Improper permission handling when copying pages (medium 6.5)
- [CVE-2024-39317](https://insights.sbomify.com/CVE-2024-39317/): Wagtail regular expression denial-of-service via search query parsing (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54263 and fix it if it is affected.

What it is: CVE-2026-54263 is a high-severity cross-site scripting vulnerability in wagtail, published on 1 Jul 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-54263 in the wild and no public exploit code.

Affected packages and fixed versions:
- wagtail (PyPI): affected from 7.3; fixed in 7.3.3, 7.4.2
- wagtail (PyPI): affected from 7.3; fixed in 7.3.3
- wagtail (PyPI): affected from 7.3; fixed in 7.3.3
- wagtail (PyPI): affected from 7.4; fixed in 7.4.2
- wagtail (PyPI): affected from 7.4; fixed in 7.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54263/ (Markdown: https://insights.sbomify.com/CVE-2026-54263/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54263
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54263
- OSV: https://osv.dev/vulnerability/CVE-2026-54263

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54263/
Summaries are generated and may contain mistakes; the official description above is the record.
