CVE-2026-54264 Angular: Sensitive Header Leakage on Cross-Origin Redirects in Angular Service Worker

High 8.3 Published Updated

Remote attackers can steal sensitive credentials like authorization tokens by triggering cross-origin redirects in the Angular Service Worker.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-54264?

CVE-2026-54264 is a high-severity vulnerability in angular, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 22.0.1, 21.2.17, and 20.3.25, an information disclosure vulnerability exists in the @angular/service-worker package of the Angular framework. When the Service Worker fetches assets, it preserves metadata (such as headers) from the original request. However, on cross-origin redirects, the Service Worker fails to strip sensitive headers, violating the Fetch redirect algorithm. This allows a remote attacker to obtain sensitive credentials (e.g., Authorization tokens, Proxy-Authorization credentials, or session cookies) by triggering a cross-origin redirect to an untrusted external origin. This vulnerability is fixed in 22.0.1, 21.2.17, and 20.3.25.

Weakness: CWE-359, CWE-200

Which versions are affected by CVE-2026-54264?

8 open source packages ship an affected version, including @angular/service-worker. It affects 1 product.

PackageAffectedFixed in
@angular/service-worker npmAll versions to 19.2.25None
@angular/service-worker npmAll versions to 19.2.25None
@angular/service-worker npmFrom 20.0.0-next.020.3.25
@angular/service-worker npmFrom 20.0.0-next.020.3.25
@angular/service-worker npmFrom 21.0.0-next.021.2.17
@angular/service-worker npmFrom 21.0.0-next.021.2.17
2 more packages
@angular/service-worker npmFrom 22.0.0-next.022.0.1
@angular/service-worker npmFrom 22.0.0-next.022.0.1

Products include Angular Angular.

How do I fix CVE-2026-54264?

Upgrade @angular/service-worker to a fixed version for your release line: 20.3.25, 21.2.17 or 22.0.1.

Is CVE-2026-54264 being exploited?

There is no known exploitation of CVE-2026-54264 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2026-54264, GHSA-qxh6-94w6-9r5p, UBUNTU-CVE-2026-54264.

Is CVE-2026-54264 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free