CVE-2026-54267 Angular Client Hydration DOM Clobbering & Response-Cache Poisoning

High 8.6 Published Updated

Attackers can hijack Angular SSR hydration state via DOM clobbering to inject malicious scripts or poison cached responses, requiring specific binding patterns.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-54267?

CVE-2026-54267 is a high-severity cross-site scripting vulnerability in angular, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 22.0.1, 21.2.17, and 20.3.25, to optimize client-side bootstrap in Server-Side Rendered (SSR) environments, Angular supports Hydration via provideClientHydration(). During SSR, Angular serializes the application's runtime state (such as cached HttpClient responses) and outputs it into the HTML stream as a <script> tag with a predictable identifier. During client bootstrap, Angular recovers this state by looking up the element via document.getElementById('ng-state') and parsing its text content. Because the DOM element lookup for the state container is predictable and relies solely on the ID selector (ng-state), it is susceptible to DOM Clobbering. If the application binds untrusted user input or CMS content to element properties such as id (e.g., <div [id]="userInput"> or <a id="ng-state">) before the genuine <script> tag is parsed by the browser, the attacker-controlled element takes precedence in the DOM lookup. During hydration, when Angular calls document.getElementById('ng-state'), the browser returns the attacker's clobbered element. Angular then attempts to parse the text content or attributes of this clobbered element as JSON. This vulnerability is fixed in 22.0.1, 21.2.17, and 20.3.25.

Weakness: CWE-79, CWE-471

Which versions are affected by CVE-2026-54267?

8 open source packages ship an affected version, including @angular/core. It affects 1 product.

PackageAffectedFixed in
@angular/core npmAll versions to 19.2.25None
@angular/core npmAll versions to 19.2.25None
@angular/core npmFrom 20.0.0-next.020.3.25
@angular/core npmFrom 20.0.0-next.020.3.25
@angular/core npmFrom 21.0.0-next.021.2.17
@angular/core npmFrom 21.0.0-next.021.2.17
2 more packages
@angular/core npmFrom 22.0.0-next.022.0.1
@angular/core npmFrom 22.0.0-next.022.0.1

Products include Angular Angular.

How do I fix CVE-2026-54267?

Upgrade @angular/core to a fixed version for your release line: 20.3.25, 21.2.17 or 22.0.1.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-54267 being exploited?

There is no known exploitation of CVE-2026-54267 in the wild and no public exploit code.

Sources

Also known as CLSA-2026-1791202115, CLSA-2026-1791202437, CLSA-2026-1791202982, CLSA-2026-1792160934, CLSA-2026-1792161412, CLSA-2026-1792161413 and 42 more.

Is CVE-2026-54267 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free