# CVE-2026-54267: Angular Client Hydration DOM Clobbering & Response-Cache Poisoning

> Attackers can hijack Angular SSR hydration state via DOM clobbering to inject malicious scripts or poison cached responses, requiring specific binding patterns.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Jun 2026
- **Updated:** 22 Jun 2026
- **Also known as:** CLSA-2026-1791202115, CLSA-2026-1791202437, CLSA-2026-1791202982, CLSA-2026-1792160934, CLSA-2026-1792161412, CLSA-2026-1792161413, CLSA-2026-1792163807, CLSA-2026-1792163808, CLSA-2026-1792163809, CLSA-2026-1792208373, CLSA-2026-1792208374, CLSA-2026-1792208375, CLSA-2026-1792250416, CLSA-2026-1792250417, CLSA-2026-1792250418, CLSA-2026-1792281554, CLSA-2026-1792281555, CLSA-2026-1792281557, CLSA-2026-1792325789, CLSA-2026-1792325791, CLSA-2026-1792325792, CLSA-2026-1792345539, CLSA-2026-1792345541, CLSA-2026-1792345543, CLSA-2026-1792357651, CLSA-2026-1792357653, CLSA-2026-1792357654, CLSA-2026-1792366811, CLSA-2026-1792366812, CLSA-2026-1792366813, CLSA-2026-1792371904, CLSA-2026-1792371905, CLSA-2026-1792371907, CLSA-2026-1792375975, CLSA-2026-1792375976, CLSA-2026-1792375977, CLSA-2026-1792380287, CLSA-2026-1792380288, CLSA-2026-1792380289, CLSA-2026-1792382842, CLSA-2026-1792382843, CLSA-2026-1792382844, CLSA-2026-1792386335, CLSA-2026-1792386336, CLSA-2026-1792386337, DEBIAN-CVE-2026-54267, GHSA-rgjc-h3x7-9mwg, UBUNTU-CVE-2026-54267

## What is CVE-2026-54267?

CVE-2026-54267 is a high-severity cross-site scripting vulnerability in angular, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 22.0.1, 21.2.17, and 20.3.25, to optimize client-side bootstrap in Server-Side Rendered (SSR) environments, Angular supports Hydration via provideClientHydration(). During SSR, Angular serializes the application's runtime state (such as cached HttpClient responses) and outputs it into the HTML stream as a <script> tag with a predictable identifier. During client bootstrap, Angular recovers this state by looking up the element via document.getElementById('ng-state') and parsing its text content. Because the DOM element lookup for the state container is predictable and relies solely on the ID selector (ng-state), it is susceptible to DOM Clobbering. If the application binds untrusted user input or CMS content to element properties such as id (e.g., <div [id]="userInput"> or <a id="ng-state">) before the genuine <script> tag is parsed by the browser, the attacker-controlled element takes precedence in the DOM lookup. During hydration, when Angular calls document.getElementById('ng-state'), the browser returns the attacker's clobbered element. Angular then attempts to parse the text content or attributes of this clobbered element as JSON. This vulnerability is fixed in 22.0.1, 21.2.17, and 20.3.25.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-471 (Modification of Assumed-Immutable Data (MAID))

## Which versions are affected by CVE-2026-54267?

8 open source packages ship an affected version, including @angular/core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@angular/core` | npm | All versions to 19.2.25 | None |
| `@angular/core` | npm | All versions to 19.2.25 | None |
| `@angular/core` | npm | From 20.0.0-next.0 | 20.3.25 |
| `@angular/core` | npm | From 20.0.0-next.0 | 20.3.25 |
| `@angular/core` | npm | From 21.0.0-next.0 | 21.2.17 |
| `@angular/core` | npm | From 21.0.0-next.0 | 21.2.17 |
| `@angular/core` | npm | From 22.0.0-next.0 | 22.0.1 |
| `@angular/core` | npm | From 22.0.0-next.0 | 22.0.1 |

Products: Angular Angular.

## How do I fix CVE-2026-54267?

Upgrade @angular/core to a fixed version for your release line: 20.3.25, 21.2.17 or 22.0.1.

## Is CVE-2026-54267 being exploited?

There is no known exploitation of CVE-2026-54267 in the wild and no public exploit code.

## Other vulnerabilities in angular

- [CVE-2026-68945](https://insights.sbomify.com/CVE-2026-68945/): Angular: Cache-Key Ambiguity in HttpTransferCache Leading to Cross-Request Response Reuse and State Poisoning (high 8.8)
- [CVE-2026-46417](https://insights.sbomify.com/CVE-2026-46417/): Angular: SSRF via Hostname Hijacking in @angular/platform-server (high 8.8)
- [CVE-2026-50168](https://insights.sbomify.com/CVE-2026-50168/): Angular: URL Parser Differential in @angular/platform-server leading to SSRF Allowlist Bypass (high 8.8)
- [CVE-2026-54266](https://insights.sbomify.com/CVE-2026-54266/): Angular: Weak 32-Bit Cache Key Hashing in `HttpTransferCache` Leading to Cross-Request Data Leakage and State Poisoning (high 8.8)
- [CVE-2026-41423](https://insights.sbomify.com/CVE-2026-41423/): Angular: SSRF via protocol-relative and backslash URLs in Angular Platform-Server (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54267 and fix it if it is affected.

What it is: CVE-2026-54267 is a high-severity cross-site scripting vulnerability in angular, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-54267 in the wild and no public exploit code.

Affected packages and fixed versions:
- @angular/core (npm): affected all versions up to 19.2.25; no fix listed
- @angular/core (npm): affected all versions up to 19.2.25; no fix listed
- @angular/core (npm): affected from 20.0.0-next.0; fixed in 20.3.25
- @angular/core (npm): affected from 20.0.0-next.0; fixed in 20.3.25
- @angular/core (npm): affected from 21.0.0-next.0; fixed in 21.2.17
- @angular/core (npm): affected from 21.0.0-next.0; fixed in 21.2.17
- @angular/core (npm): affected from 22.0.0-next.0; fixed in 22.0.1
- @angular/core (npm): affected from 22.0.0-next.0; fixed in 22.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54267/ (Markdown: https://insights.sbomify.com/CVE-2026-54267/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54267
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54267
- OSV: https://osv.dev/vulnerability/CVE-2026-54267

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54267/
Summaries are generated and may contain mistakes; the official description above is the record.
