CVE-2026-54268 Angular: Denial of Service (DoS) via OOM in Date Formatting (formatDate)

High 8.2 Published Updated

Attackers can cause denial of service in Angular applications by supplying excessively long date format strings to the formatDate function, leading to resource exhaustion.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-54268?

CVE-2026-54268 is a high-severity denial of service vulnerability in angular, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 22.0.1, 21.2.17, and 20.3.25, a Denial of Service (DoS) vulnerability exists in the @angular/common package of the Angular framework. The formatDate function, which is also utilized by the standard Angular DatePipe, does not properly limit or validate the length of the format parameter. When parsing a maliciously crafted, excessively long date format string (e.g., a repeating pattern or very large string), the internal parser splits the string iteratively using a regular expression loop. This results in uncontrolled resource consumption (high CPU utilization and excessive memory allocations), leading to a Denial of Service (DoS). This vulnerability is fixed in 22.0.1, 21.2.17, and 20.3.25.

Weakness: CWE-400, CWE-1333

Which versions are affected by CVE-2026-54268?

8 open source packages ship an affected version, including @angular/common. It affects 1 product.

PackageAffectedFixed in
@angular/common npmAll versions to 19.2.25None
@angular/common npmAll versions to 19.2.25None
@angular/common npmFrom 20.0.0-next.020.3.25
@angular/common npmFrom 20.0.0-next.020.3.25
@angular/common npmFrom 21.0.0-next.021.2.17
@angular/common npmFrom 21.0.0-next.021.2.17
2 more packages
@angular/common npmFrom 22.0.0-next.022.0.1
@angular/common npmFrom 22.0.0-next.022.0.1

Products include Angular Angular.

How do I fix CVE-2026-54268?

Upgrade @angular/common to a fixed version for your release line: 20.3.25, 21.2.17 or 22.0.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-54268 being exploited?

There is no known exploitation of CVE-2026-54268 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2026-54268, GHSA-48r7-hpm6-gfxm, UBUNTU-CVE-2026-54268.

Is CVE-2026-54268 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free