# CVE-2026-54268: Angular: Denial of Service (DoS) via OOM in Date Formatting (formatDate)

> Attackers can cause denial of service in Angular applications by supplying excessively long date format strings to the formatDate function, leading to resource exhaustion.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jun 2026
- **Updated:** 23 Jun 2026
- **Also known as:** DEBIAN-CVE-2026-54268, GHSA-48r7-hpm6-gfxm, UBUNTU-CVE-2026-54268

## What is CVE-2026-54268?

CVE-2026-54268 is a high-severity denial of service vulnerability in angular, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 22.0.1, 21.2.17, and 20.3.25, a Denial of Service (DoS) vulnerability exists in the @angular/common package of the Angular framework. The formatDate function, which is also utilized by the standard Angular DatePipe, does not properly limit or validate the length of the format parameter. When parsing a maliciously crafted, excessively long date format string (e.g., a repeating pattern or very large string), the internal parser splits the string iteratively using a regular expression loop. This results in uncontrolled resource consumption (high CPU utilization and excessive memory allocations), leading to a Denial of Service (DoS). This vulnerability is fixed in 22.0.1, 21.2.17, and 20.3.25.

Weakness: CWE-400 (Uncontrolled Resource Consumption), CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2026-54268?

8 open source packages ship an affected version, including @angular/common. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@angular/common` | npm | All versions to 19.2.25 | None |
| `@angular/common` | npm | All versions to 19.2.25 | None |
| `@angular/common` | npm | From 20.0.0-next.0 | 20.3.25 |
| `@angular/common` | npm | From 20.0.0-next.0 | 20.3.25 |
| `@angular/common` | npm | From 21.0.0-next.0 | 21.2.17 |
| `@angular/common` | npm | From 21.0.0-next.0 | 21.2.17 |
| `@angular/common` | npm | From 22.0.0-next.0 | 22.0.1 |
| `@angular/common` | npm | From 22.0.0-next.0 | 22.0.1 |

Products: Angular Angular.

## How do I fix CVE-2026-54268?

Upgrade @angular/common to a fixed version for your release line: 20.3.25, 21.2.17 or 22.0.1.

## Is CVE-2026-54268 being exploited?

There is no known exploitation of CVE-2026-54268 in the wild and no public exploit code.

## Other vulnerabilities in angular

- [CVE-2026-68945](https://insights.sbomify.com/CVE-2026-68945/): Angular: Cache-Key Ambiguity in HttpTransferCache Leading to Cross-Request Response Reuse and State Poisoning (high 8.8)
- [CVE-2026-46417](https://insights.sbomify.com/CVE-2026-46417/): Angular: SSRF via Hostname Hijacking in @angular/platform-server (high 8.8)
- [CVE-2026-50168](https://insights.sbomify.com/CVE-2026-50168/): Angular: URL Parser Differential in @angular/platform-server leading to SSRF Allowlist Bypass (high 8.8)
- [CVE-2026-54266](https://insights.sbomify.com/CVE-2026-54266/): Angular: Weak 32-Bit Cache Key Hashing in `HttpTransferCache` Leading to Cross-Request Data Leakage and State Poisoning (high 8.8)
- [CVE-2026-41423](https://insights.sbomify.com/CVE-2026-41423/): Angular: SSRF via protocol-relative and backslash URLs in Angular Platform-Server (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54268 and fix it if it is affected.

What it is: CVE-2026-54268 is a high-severity denial of service vulnerability in angular, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-54268 in the wild and no public exploit code.

Affected packages and fixed versions:
- @angular/common (npm): affected all versions up to 19.2.25; no fix listed
- @angular/common (npm): affected all versions up to 19.2.25; no fix listed
- @angular/common (npm): affected from 20.0.0-next.0; fixed in 20.3.25
- @angular/common (npm): affected from 20.0.0-next.0; fixed in 20.3.25
- @angular/common (npm): affected from 21.0.0-next.0; fixed in 21.2.17
- @angular/common (npm): affected from 21.0.0-next.0; fixed in 21.2.17
- @angular/common (npm): affected from 22.0.0-next.0; fixed in 22.0.1
- @angular/common (npm): affected from 22.0.0-next.0; fixed in 22.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54268/ (Markdown: https://insights.sbomify.com/CVE-2026-54268/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54268
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54268
- OSV: https://osv.dev/vulnerability/CVE-2026-54268

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54268/
Summaries are generated and may contain mistakes; the official description above is the record.
