# CVE-2026-54273: AIOHTTP: HTTP/1 Pipelined Requests Queue Without Limit

> Attackers can exhaust server memory by sending unlimited pipelined HTTP requests, causing denial of service in applications using the aiohttp library.

- **Severity:** Medium 6.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jun 2026
- **Updated:** 22 Jun 2026
- **Also known as:** AZL-90650, CLEANSTART-2026-DT07789, CLEANSTART-2026-OZ78618, DEBIAN-CVE-2026-54273, ECHO-7903-2043-8947, GHSA-4fvr-rgm6-gqmc, MINI-3fmf-c427-vmjw, MINI-42pj-8mqf-4mxw, MINI-4mx3-3mvj-8pm9, MINI-4vj4-r45w-wv2r, MINI-5x3r-m395-c6hc, MINI-67rx-rprx-gwmh, MINI-7f93-vrc7-q3r7, MINI-979r-cfqq-mcr7, MINI-f2rj-692x-cjcf, MINI-h853-mhp6-qhq8, MINI-m6j9-c6qq-9f6v, MINI-q5vf-2f7w-mgvv, MINI-qg29-85v9-j3fv, MINI-r7x8-4f74-mwc7, MINI-vqp6-mhmp-23rc, MINI-whj7-xw9q-fr53, MINI-wjmj-fqf2-7h85, PYSEC-2026-2107, ROOT-APP-PYPI-CVE-2026-54273, UBUNTU-CVE-2026-54273

## What is CVE-2026-54273?

CVE-2026-54273 is a medium-severity denial of service vulnerability in aio-libs aiohttp, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

AIOHTTP is an asynchronous HTTP client/server framework for asyncio and Python. Prior to 3.14.1, no limit was present on the number of pipelined requests that could be queued. An attacker may be able to use pipelined requests to use excessive amounts of memory, potentially leading to DoS. This vulnerability is fixed in 3.14.1.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-54273?

3 open source packages ship an affected version, including aiohttp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `aiohttp` | PyPI | All versions | 3.14.1 |
| `aiohttp` | PyPI | All versions | 3.14.1 |
| `aiohttp` | PyPI | All versions | 3.14.1 |

Products: Aiohttp Aiohttp.

## How do I fix CVE-2026-54273?

Upgrade aiohttp to 3.14.1 or later.

## Is CVE-2026-54273 being exploited?

There is no known exploitation of CVE-2026-54273 in the wild and no public exploit code.

## Other vulnerabilities in aio-libs aiohttp

- [CVE-2024-52303](https://insights.sbomify.com/CVE-2024-52303/): aiohttp memory leak when middleware is enabled when requesting a resource with a non-allowed method (high 8.7)
- [CVE-2025-69223](https://insights.sbomify.com/CVE-2025-69223/): AIOHTTP's HTTP Parser auto_decompress feature is vulnerable to zip bomb (high 7.5)
- [CVE-2024-30251](https://insights.sbomify.com/CVE-2024-30251/): Denial of service when trying to parse malformed POST requests in aiohttp (high 7.5)
- [CVE-2023-49081](https://insights.sbomify.com/CVE-2023-49081/): aiohttp's ClientSession is vulnerable to CRLF injection via version (high 7.2)
- [CVE-2026-22815](https://insights.sbomify.com/CVE-2026-22815/): AIOHTTP: Uncapped memory usage possible through aiohttp allowing unlimited trailer headers (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54273 and fix it if it is affected.

What it is: CVE-2026-54273 is a medium-severity denial of service vulnerability in aio-libs aiohttp, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-54273 in the wild and no public exploit code.

Affected packages and fixed versions:
- aiohttp (PyPI): affected all versions; fixed in 3.14.1
- aiohttp (PyPI): affected all versions; fixed in 3.14.1
- aiohttp (PyPI): affected all versions; fixed in 3.14.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54273/ (Markdown: https://insights.sbomify.com/CVE-2026-54273/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54273
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54273
- OSV: https://osv.dev/vulnerability/CVE-2026-54273

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54273/
Summaries are generated and may contain mistakes; the official description above is the record.
