# CVE-2026-54275: AIOHTTP: TLS Server Hostname Override Is Ignored When Reusing HTTPS Connections

> Attackers can bypass TLS hostname verification in aiohttp by reusing connections, potentially enabling man-in-the-middle attacks against applications using the library.

- **Severity:** Low 2.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jun 2026
- **Updated:** 22 Jun 2026
- **Also known as:** CLEANSTART-2026-QD31009, CLEANSTART-2026-YI50713, DEBIAN-CVE-2026-54275, ECHO-3b67-4bd3-d8be, GHSA-4m7w-qmgq-4wj5, MINI-4m8q-c56p-c9hh, MINI-66vg-mr64-gh85, MINI-68wj-9j26-jj3p, MINI-86v5-5969-qfw8, MINI-8hxf-ww5c-v952, MINI-965g-fvcf-wjpf, MINI-9x7j-54jc-mp96, MINI-h8xp-99c5-73h3, MINI-ph2f-69pf-3v4x, MINI-pp44-wgx8-2m99, MINI-q73m-f7mw-f4m4, MINI-qj3r-q5q4-rwqr, MINI-rhrc-rqv8-v6cg, MINI-rr9q-pqxg-m44c, MINI-v725-8rv2-6h7p, MINI-v7v2-wfmr-g49p, MINI-v9rg-6gw8-759q, PYSEC-2026-237, ROOT-APP-PYPI-CVE-2026-54275, UBUNTU-CVE-2026-54275

## What is CVE-2026-54275?

CVE-2026-54275 is a low-severity vulnerability in aio-libs aiohttp, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

AIOHTTP is an asynchronous HTTP client/server framework for asyncio and Python. Prior to 3.14.1, the server_hostname TLS SNI check can be bypassed when an existing connection is reused. If an application makes multiple requests to the same domain, but with different per-request server_hostname parameters, then the later calls may succeed by reusing the existing connection when they should have been rejected due to the TLS SNI check. This vulnerability is fixed in 3.14.1.

Weakness: CWE-297 (Improper Validation of Certificate with Host Mismatch)

## Which versions are affected by CVE-2026-54275?

3 open source packages ship an affected version, including aiohttp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `aiohttp` | PyPI | All versions | 3.14.1 |
| `aiohttp` | PyPI | All versions | 3.14.1 |
| `aiohttp` | PyPI | All versions | 3.14.1 |

Products: Aiohttp Aiohttp.

## How do I fix CVE-2026-54275?

Upgrade aiohttp to 3.14.1 or later.

## Is CVE-2026-54275 being exploited?

There is no known exploitation of CVE-2026-54275 in the wild and no public exploit code.

## Other vulnerabilities in aio-libs aiohttp

- [CVE-2024-52303](https://insights.sbomify.com/CVE-2024-52303/): aiohttp memory leak when middleware is enabled when requesting a resource with a non-allowed method (high 8.7)
- [CVE-2025-69223](https://insights.sbomify.com/CVE-2025-69223/): AIOHTTP's HTTP Parser auto_decompress feature is vulnerable to zip bomb (high 7.5)
- [CVE-2024-30251](https://insights.sbomify.com/CVE-2024-30251/): Denial of service when trying to parse malformed POST requests in aiohttp (high 7.5)
- [CVE-2023-49081](https://insights.sbomify.com/CVE-2023-49081/): aiohttp's ClientSession is vulnerable to CRLF injection via version (high 7.2)
- [CVE-2026-22815](https://insights.sbomify.com/CVE-2026-22815/): AIOHTTP: Uncapped memory usage possible through aiohttp allowing unlimited trailer headers (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54275 and fix it if it is affected.

What it is: CVE-2026-54275 is a low-severity vulnerability in aio-libs aiohttp, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-54275 in the wild and no public exploit code.

Affected packages and fixed versions:
- aiohttp (PyPI): affected all versions; fixed in 3.14.1
- aiohttp (PyPI): affected all versions; fixed in 3.14.1
- aiohttp (PyPI): affected all versions; fixed in 3.14.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54275/ (Markdown: https://insights.sbomify.com/CVE-2026-54275/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54275
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54275
- OSV: https://osv.dev/vulnerability/CVE-2026-54275

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54275/
Summaries are generated and may contain mistakes; the official description above is the record.
