# CVE-2026-54276: AIOHTTP: DigestAuthMiddleware Applies Credentials to Cross-Origin Redirect Challenges

> AIOHTTP's DigestAuthMiddleware may leak user credentials to cross-origin redirect targets, allowing attackers to potentially recover sensitive authentication data.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jun 2026
- **Updated:** 23 Jun 2026
- **Also known as:** CLEANSTART-2026-LF30354, CLEANSTART-2026-WD11745, DEBIAN-CVE-2026-54276, ECHO-063c-9c61-c3d6, GHSA-hpj7-wq8m-9hgp, MINI-5249-7v73-j4m3, MINI-6xm5-3fv8-rqj7, MINI-74j9-wxm5-8x4w, MINI-7jg4-cv7c-fhjh, MINI-92hf-cx59-r652, MINI-9p86-9m9f-5j95, MINI-cpjj-j3xj-5ch8, MINI-g6q8-wv28-r9h4, MINI-gcp3-wmx5-6qff, MINI-ghqf-5fwg-f275, MINI-j7cw-pp2m-f5gj, MINI-j7qr-2w2h-m5m9, MINI-pfvf-9qq6-c35m, MINI-q974-h3q4-2qfv, MINI-r54q-297h-3jjg, MINI-rqqr-844g-hxgp, MINI-xcgw-xh5f-xp46, PYSEC-2026-2109, ROOT-APP-PYPI-CVE-2026-54276, UBUNTU-CVE-2026-54276

## What is CVE-2026-54276?

CVE-2026-54276 is a medium-severity vulnerability in aio-libs aiohttp, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

AIOHTTP is an asynchronous HTTP client/server framework for asyncio and Python. Prior to 3.14.1, DigestAuthMiddleware can send an authentication response after following a cross-origin redirect. This likely requires an open redirect vulnerability or similar on the target domain for an attacker to be able to execute. Further, the attacker is only receiving the digest, so should only be able to extract the user's credentials if the cryptography is weak or there is some kind of password reuse. This vulnerability is fixed in 3.14.1.

Weakness: CWE-601 (URL Redirection to Untrusted Site), CWE-522 (Insufficiently Protected Credentials), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-54276?

3 open source packages ship an affected version, including aiohttp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `aiohttp` | PyPI | All versions | 3.14.1 |
| `aiohttp` | PyPI | All versions | 3.14.1 |
| `aiohttp` | PyPI | All versions | 3.14.1 |

Products: Aiohttp Aiohttp.

## How do I fix CVE-2026-54276?

Upgrade aiohttp to 3.14.1 or later.

## Is CVE-2026-54276 being exploited?

There is no known exploitation of CVE-2026-54276 in the wild and no public exploit code.

## Other vulnerabilities in aio-libs aiohttp

- [CVE-2024-52303](https://insights.sbomify.com/CVE-2024-52303/): aiohttp memory leak when middleware is enabled when requesting a resource with a non-allowed method (high 8.7)
- [CVE-2025-69223](https://insights.sbomify.com/CVE-2025-69223/): AIOHTTP's HTTP Parser auto_decompress feature is vulnerable to zip bomb (high 7.5)
- [CVE-2024-30251](https://insights.sbomify.com/CVE-2024-30251/): Denial of service when trying to parse malformed POST requests in aiohttp (high 7.5)
- [CVE-2023-49081](https://insights.sbomify.com/CVE-2023-49081/): aiohttp's ClientSession is vulnerable to CRLF injection via version (high 7.2)
- [CVE-2026-22815](https://insights.sbomify.com/CVE-2026-22815/): AIOHTTP: Uncapped memory usage possible through aiohttp allowing unlimited trailer headers (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54276 and fix it if it is affected.

What it is: CVE-2026-54276 is a medium-severity vulnerability in aio-libs aiohttp, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-54276 in the wild and no public exploit code.

Affected packages and fixed versions:
- aiohttp (PyPI): affected all versions; fixed in 3.14.1
- aiohttp (PyPI): affected all versions; fixed in 3.14.1
- aiohttp (PyPI): affected all versions; fixed in 3.14.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54276/ (Markdown: https://insights.sbomify.com/CVE-2026-54276/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54276
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54276
- OSV: https://osv.dev/vulnerability/CVE-2026-54276

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54276/
Summaries are generated and may contain mistakes; the official description above is the record.
