# CVE-2026-54277: AIOHTTP: C HTTP Parser Bypasses max_line_size for Fragmented Lines

> Attackers can cause denial of service by sending oversized HTTP lines that bypass memory limits in the default C parser.

- **Severity:** Medium 6.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jun 2026
- **Updated:** 23 Jun 2026
- **Also known as:** AZL-90671, CLEANSTART-2026-JS34043, CLEANSTART-2026-TM43403, DEBIAN-CVE-2026-54277, ECHO-c85b-77dd-0d28, GHSA-63hw-fmq6-xxg2, MINI-2wwp-5w84-68f5, MINI-5956-rp8m-84fv, MINI-6hrq-3gg4-pmq9, MINI-7jm6-v2r4-5p29, MINI-7jpr-f873-h4cr, MINI-7q2j-mcmh-7hfg, MINI-8635-mc5p-qqmg, MINI-9q5m-h7pv-m2xx, MINI-cp62-gr64-x23r, MINI-g55x-4578-8272, MINI-h4rh-9p8c-8jf9, MINI-h8jm-53cr-fq9h, MINI-hp5f-rxr3-c5p3, MINI-ph3r-rgg3-r422, MINI-q6pr-qg4g-5qv7, MINI-vc2h-xwmf-46mf, MINI-x9g2-mvmh-wh43, PYSEC-2026-2110, ROOT-APP-PYPI-CVE-2026-54277, UBUNTU-CVE-2026-54277

## What is CVE-2026-54277?

CVE-2026-54277 is a medium-severity denial of service vulnerability in aio-libs aiohttp, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

AIOHTTP is an asynchronous HTTP client/server framework for asyncio and Python. Prior to 3.14.1, it is possible to bypass the max_line_size check in parts of an HTTP request in the C parser. If using the optimised C parser (the default in pre-built wheels), then an attacker may be able to send oversized lines through the HTTP parser and use an excessive amount of memory, potentially leading to DoS. This vulnerability is fixed in 3.14.1.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-54277?

3 open source packages ship an affected version, including aiohttp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `aiohttp` | PyPI | All versions | 3.14.1 |
| `aiohttp` | PyPI | All versions | 3.14.1 |
| `aiohttp` | PyPI | All versions | 3.14.1 |

Products: Aiohttp Aiohttp.

## How do I fix CVE-2026-54277?

Upgrade aiohttp to 3.14.1 or later.

## Is CVE-2026-54277 being exploited?

There is no known exploitation of CVE-2026-54277 in the wild and no public exploit code.

## Other vulnerabilities in aio-libs aiohttp

- [CVE-2024-52303](https://insights.sbomify.com/CVE-2024-52303/): aiohttp memory leak when middleware is enabled when requesting a resource with a non-allowed method (high 8.7)
- [CVE-2025-69223](https://insights.sbomify.com/CVE-2025-69223/): AIOHTTP's HTTP Parser auto_decompress feature is vulnerable to zip bomb (high 7.5)
- [CVE-2024-30251](https://insights.sbomify.com/CVE-2024-30251/): Denial of service when trying to parse malformed POST requests in aiohttp (high 7.5)
- [CVE-2023-49081](https://insights.sbomify.com/CVE-2023-49081/): aiohttp's ClientSession is vulnerable to CRLF injection via version (high 7.2)
- [CVE-2026-22815](https://insights.sbomify.com/CVE-2026-22815/): AIOHTTP: Uncapped memory usage possible through aiohttp allowing unlimited trailer headers (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54277 and fix it if it is affected.

What it is: CVE-2026-54277 is a medium-severity denial of service vulnerability in aio-libs aiohttp, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-54277 in the wild and no public exploit code.

Affected packages and fixed versions:
- aiohttp (PyPI): affected all versions; fixed in 3.14.1
- aiohttp (PyPI): affected all versions; fixed in 3.14.1
- aiohttp (PyPI): affected all versions; fixed in 3.14.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54277/ (Markdown: https://insights.sbomify.com/CVE-2026-54277/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54277
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54277
- OSV: https://osv.dev/vulnerability/CVE-2026-54277

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54277/
Summaries are generated and may contain mistakes; the official description above is the record.
