# CVE-2026-54281: Nest: Middleware Bypass on Fastify via Trailing Slash

> Attackers can bypass authentication middleware in NestJS Fastify applications by appending a trailing slash to URLs, allowing unauthorized access to protected routes.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jun 2026
- **Updated:** 24 Jun 2026
- **Also known as:** GHSA-6v32-fjc9-9qf6

## What is CVE-2026-54281?

CVE-2026-54281 is a high-severity authentication bypass vulnerability in nestjs nest, published on 22 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Nest is a framework for building scalable Node.js server-side applications. Prior to 11.1.24, an authentication bypass vulnerability exists in @nestjs/platform-fastify. When middleware is registered through NestJS's MiddlewareConsumer.forRoutes() API on the Fastify adapter, an unauthenticated client can bypass the Nest middleware registered for that route by simply appending a trailing slash (/) to the request URL. This bypass works on the default Fastify adapter configuration. This vulnerability is fixed in 11.1.24.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-54281?

2 open source packages ship an affected version, including @nestjs/platform-fastify.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@nestjs/platform-fastify` | npm | All versions | 11.1.24 |
| `@nestjs/platform-fastify` | npm | All versions | 11.1.24 |

## How do I fix CVE-2026-54281?

Upgrade @nestjs/platform-fastify to 11.1.24 or later.

## Is CVE-2026-54281 being exploited?

There is no known exploitation of CVE-2026-54281 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54281 and fix it if it is affected.

What it is: CVE-2026-54281 is a high-severity authentication bypass vulnerability in nestjs nest, published on 22 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-54281 in the wild and no public exploit code.

Affected packages and fixed versions:
- @nestjs/platform-fastify (npm): affected all versions; fixed in 11.1.24
- @nestjs/platform-fastify (npm): affected all versions; fixed in 11.1.24

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54281/ (Markdown: https://insights.sbomify.com/CVE-2026-54281/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54281
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54281
- OSV: https://osv.dev/vulnerability/CVE-2026-54281

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54281/
Summaries are generated and may contain mistakes; the official description above is the record.
