# CVE-2026-54282: Starlette: Unvalidated request path concatenated into authority poisons request.url.hostname

> Attackers can spoof the request hostname in Starlette by manipulating the path, potentially bypassing host-based security checks.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jun 2026
- **Updated:** 22 Jun 2026
- **Also known as:** CLEANSTART-2026-EW07034, CLEANSTART-2026-PS49478, CLSA-2026-1784077472, DEBIAN-CVE-2026-54282, ECHO-c63d-05ac-97df, GHSA-jp82-jpqv-5vv3, MINI-22j9-m83c-jg7p, MINI-2666-2rgc-h329, MINI-3jmw-8xv7-2wpv, MINI-3qfg-gmfj-656w, MINI-7xpq-qqgm-mqpf, MINI-cfr3-f93v-7rh7, MINI-gv74-4383-9g7j, MINI-h8gj-hwm5-mfgv, MINI-hjp2-5v5v-92gj, MINI-j66c-8rqw-x2hp, MINI-m44v-4x86-5fch, MINI-pq4m-c4qp-5xh8, MINI-qx23-g92p-mvh9, MINI-rwwr-3p8j-j7cv, MINI-vpg9-9pmp-j6rp, MINI-wr87-gj26-69fc, MINI-x5m4-c4mw-qv2h, PYSEC-2026-248, ROOT-APP-PYPI-CVE-2026-54282, UBUNTU-CVE-2026-54282, openSUSE-SU-2026:11058-1

## What is CVE-2026-54282?

CVE-2026-54282 is a low-severity vulnerability in Kludex starlette, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Starlette is a lightweight ASGI framework/toolkit. Prior to 1.3.0, the HTTP request path is not validated before being used to reconstruct request.url. Because request.url is rebuilt by concatenating {scheme}://{host}{path} and re-parsing the result, a path that does not begin with / (for example @google.com) moves the authority boundary during re-parsing, so request.url.hostname and request.url.netloc become attacker-controlled. Code that reads request.url.hostname (rather than the Host header or scope) can therefore be misled into trusting an attacker-supplied host. This vulnerability is fixed in 1.3.0.

Weakness: CWE-706 (Use of Incorrectly-Resolved Name or Reference)

## Which versions are affected by CVE-2026-54282?

3 open source packages ship an affected version, including starlette and Starlette. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `starlette` | PyPI | All versions | 1.3.0 |
| `starlette` | PyPI | All versions | 1.3.0 |
| `Starlette` | PyPI | All versions | 1.3.0 |
| `python-starlette` | openSUSE:Tumbleweed | All versions | 1.3.1-1.1 |

Products: Encode Starlette.

## How do I fix CVE-2026-54282?

Upgrade starlette to 1.3.0 or later.

## Is CVE-2026-54282 being exploited?

There is no known exploitation of CVE-2026-54282 in the wild and no public exploit code.

## Other vulnerabilities in Kludex starlette

- [CVE-2026-48710](https://insights.sbomify.com/CVE-2026-48710/): Kludex Starlette HTTP Request/Response Smuggling (medium 6.5, exploited in the wild)
- [CVE-2026-54283](https://insights.sbomify.com/CVE-2026-54283/): Starlette: request.form() limits silently ignored for application/x-www-form-urlencoded enable DoS (high 7.5)
- [CVE-2026-48818](https://insights.sbomify.com/CVE-2026-48818/): Starlette: SSRF and NTLM credential theft via UNC paths in StaticFiles on Windows (high 7.5)
- [CVE-2023-29159](https://insights.sbomify.com/CVE-2023-29159/): Starlette has Path Traversal vulnerability in StaticFiles (high 7.5)
- [CVE-2023-30798](https://insights.sbomify.com/CVE-2023-30798/): MultipartParser DOS with too many fields or files in Starlette Framework (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54282 and fix it if it is affected.

What it is: CVE-2026-54282 is a low-severity vulnerability in Kludex starlette, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-54282 in the wild and no public exploit code.

Affected packages and fixed versions:
- starlette (PyPI): affected all versions; fixed in 1.3.0
- starlette (PyPI): affected all versions; fixed in 1.3.0
- Starlette (PyPI): affected all versions; fixed in 1.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54282/ (Markdown: https://insights.sbomify.com/CVE-2026-54282/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54282
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54282
- OSV: https://osv.dev/vulnerability/CVE-2026-54282

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54282/
Summaries are generated and may contain mistakes; the official description above is the record.
