# CVE-2026-54283: Starlette: request.form() limits silently ignored for application/x-www-form-urlencoded enable DoS

> An unauthenticated attacker can cause denial of service by sending large urlencoded form data, bypassing configured resource limits in Starlette.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jun 2026
- **Updated:** 23 Jun 2026
- **Also known as:** CLEANSTART-2026-PN29190, CLEANSTART-2026-SB78573, CLSA-2026-1782954022, DEBIAN-CVE-2026-54283, ECHO-9688-fa29-3d55, GHSA-82w8-qh3p-5jfq, MINI-2p56-j3fp-86c4, MINI-32pf-w8w6-9x57, MINI-3xr5-9rrm-566w, MINI-5xpq-wfpj-72c7, MINI-7ch9-vmfq-4j5x, MINI-7r7c-32j8-485j, MINI-8xvf-vw83-hr5g, MINI-f255-7cc6-c8hq, MINI-g67m-mv2m-gcm5, MINI-jhg8-q7gc-rm8m, MINI-jr3q-5w3h-ccjw, MINI-qg42-3vp5-gqq6, MINI-qpj8-p6wf-c854, MINI-rpj4-7jq4-5gqc, MINI-rxqm-c5cv-qjrr, MINI-vg52-944r-4mph, MINI-x56h-7r3r-xwjf, PYSEC-2026-249, ROOT-APP-PYPI-CVE-2026-54283, UBUNTU-CVE-2026-54283

## What is CVE-2026-54283?

CVE-2026-54283 is a high-severity denial of service vulnerability in Kludex starlette, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Starlette is a lightweight ASGI framework/toolkit. From 0.4.1 until 1.3.1, request.form() accepts max_fields and max_part_size to bound resource consumption while parsing form data. These limits are enforced for multipart/form-data, but silently ignored for application/x-www-form-urlencoded. An unauthenticated attacker can therefore send a urlencoded body with an arbitrarily large number of fields or an arbitrarily large field, even when the application configured limits it believed would apply. This vulnerability is fixed in 1.3.1.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-54283?

3 open source packages ship an affected version, including starlette. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `starlette` | PyPI | From 0.4.1 | 1.3.1 |
| `starlette` | PyPI | From 0.4.1 | 1.3.1 |
| `starlette` | PyPI | From 0.4.1 | 1.3.1 |

Products: Encode Starlette.

## How do I fix CVE-2026-54283?

Upgrade starlette to 1.3.1 or later.

## Is CVE-2026-54283 being exploited?

There is no known exploitation of CVE-2026-54283 in the wild and no public exploit code.

## Other vulnerabilities in Kludex starlette

- [CVE-2026-48710](https://insights.sbomify.com/CVE-2026-48710/): Kludex Starlette HTTP Request/Response Smuggling (medium 6.5, exploited in the wild)
- [CVE-2026-48818](https://insights.sbomify.com/CVE-2026-48818/): Starlette: SSRF and NTLM credential theft via UNC paths in StaticFiles on Windows (high 7.5)
- [CVE-2023-29159](https://insights.sbomify.com/CVE-2023-29159/): Starlette has Path Traversal vulnerability in StaticFiles (high 7.5)
- [CVE-2023-30798](https://insights.sbomify.com/CVE-2023-30798/): MultipartParser DOS with too many fields or files in Starlette Framework (high 7.5)
- [CVE-2026-48817](https://insights.sbomify.com/CVE-2026-48817/): Starlette: Arbitrary HTTP method dispatched to `HTTPEndpoint` attributes via `getattr` (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54283 and fix it if it is affected.

What it is: CVE-2026-54283 is a high-severity denial of service vulnerability in Kludex starlette, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-54283 in the wild and no public exploit code.

Affected packages and fixed versions:
- starlette (PyPI): affected from 0.4.1; fixed in 1.3.1
- starlette (PyPI): affected from 0.4.1; fixed in 1.3.1
- starlette (PyPI): affected from 0.4.1; fixed in 1.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54283/ (Markdown: https://insights.sbomify.com/CVE-2026-54283/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54283
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54283
- OSV: https://osv.dev/vulnerability/CVE-2026-54283

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54283/
Summaries are generated and may contain mistakes; the official description above is the record.
