# CVE-2026-54287: hono: AWS Lambda adapter merges multiple `Set-Cookie` headers into one value, dropping cookies on ALB single-header and Lattice

> Hono framework incorrectly merges Set-Cookie headers on AWS Lambda, causing clients to drop cookies and potentially bypass authentication or session controls.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jun 2026
- **Updated:** 22 Jun 2026
- **Also known as:** ECHO-55ba-b30a-0691, GHSA-j6c9-x7qj-28xf, MINI-2hgr-73jr-9f2r, MINI-2rjm-4g68-57c6, MINI-78g2-r3mc-p2p4, MINI-7vm2-xw2w-6ggp, MINI-85pj-wj5p-9x92, MINI-c944-vmf6-xmxm, MINI-cc45-f2x5-8rhh, MINI-hf8x-63c9-g428, MINI-hh2p-f623-42fr, MINI-q2wp-m5pp-mm2j, MINI-xgx3-mxw9-qchw, MINI-xm64-gx99-347q, ROOT-APP-NPM-CVE-2026-54287

## What is CVE-2026-54287?

CVE-2026-54287 is a medium-severity vulnerability in honojs hono, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Hono is a Web application framework that provides support for any JavaScript runtime. Prior to 4.12.25, on AWS Lambda, the ALB single-header response and the VPC Lattice v2 response join multiple Set-Cookie headers into one comma-separated value. Because commas also appear inside cookie attributes (for example Expires dates), clients cannot split the value back into individual cookies and silently drop or misparse them. This vulnerability is fixed in 4.12.25.

Weakness: CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2026-54287?

2 open source packages ship an affected version, including hono.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `hono` | npm | All versions | 4.12.25 |
| `hono` | npm | All versions | 4.12.25 |

## How do I fix CVE-2026-54287?

Upgrade hono to 4.12.25 or later.

## Is CVE-2026-54287 being exploited?

There is no known exploitation of CVE-2026-54287 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54287 and fix it if it is affected.

What it is: CVE-2026-54287 is a medium-severity vulnerability in honojs hono, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-54287 in the wild and no public exploit code.

Affected packages and fixed versions:
- hono (npm): affected all versions; fixed in 4.12.25
- hono (npm): affected all versions; fixed in 4.12.25

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54287/ (Markdown: https://insights.sbomify.com/CVE-2026-54287/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54287
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54287
- OSV: https://osv.dev/vulnerability/CVE-2026-54287

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54287/
Summaries are generated and may contain mistakes; the official description above is the record.
