# CVE-2026-54290: Hono: CORS Middleware reflects any Origin with credentials when `origin` defaults to the wildcard

> The Hono CORS middleware incorrectly reflects any origin with credentials enabled, allowing attackers to read sensitive data from cookie-authenticated endpoints.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Jun 2026
- **Updated:** 22 Jun 2026
- **Also known as:** ECHO-dd9a-5b55-e04b, GHSA-88fw-hqm2-52qc, MINI-26jm-m79r-mw4j, MINI-4cjp-p875-3fm6, MINI-5273-prf6-h7f2, MINI-59vq-vf5w-3rhx, MINI-5g6w-2mhp-9pw6, MINI-5vf5-fj78-823g, MINI-662f-gpqv-m2g4, MINI-78fj-9wq6-2g82, MINI-m6fg-64jv-f4f4, MINI-m6p7-c3xv-674c, MINI-mxm2-pwh7-43q4, MINI-p8qm-q4fq-vc3f, MINI-qqp3-7q5f-xppx, ROOT-APP-NPM-CVE-2026-54290

## What is CVE-2026-54290?

CVE-2026-54290 is a high-severity vulnerability in honojs hono, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Hono is a Web application framework that provides support for any JavaScript runtime. Prior to 4.12.25, with credentials: true and no explicit origin (the default wildcard), the CORS Middleware reflects the request's Origin and sends Access-Control-Allow-Credentials: true. Any site can then make credentialed cross-origin requests and read the responses, exposing cookie-authenticated endpoints to arbitrary origins. This vulnerability is fixed in 4.12.25.

Weakness: CWE-942 (Permissive Cross-domain Security Policy with Untrusted Domains)

## Which versions are affected by CVE-2026-54290?

2 open source packages ship an affected version, including hono.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `hono` | npm | All versions | 4.12.25 |
| `hono` | npm | All versions | 4.12.25 |

## How do I fix CVE-2026-54290?

Upgrade hono to 4.12.25 or later.

## Is CVE-2026-54290 being exploited?

There is no known exploitation of CVE-2026-54290 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54290 and fix it if it is affected.

What it is: CVE-2026-54290 is a high-severity vulnerability in honojs hono, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-54290 in the wild and no public exploit code.

Affected packages and fixed versions:
- hono (npm): affected all versions; fixed in 4.12.25
- hono (npm): affected all versions; fixed in 4.12.25

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54290/ (Markdown: https://insights.sbomify.com/CVE-2026-54290/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54290
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54290
- OSV: https://osv.dev/vulnerability/CVE-2026-54290

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54290/
Summaries are generated and may contain mistakes; the official description above is the record.
