# CVE-2026-54291: Silent channel-binding authentication downgrade via unsupported certificate algorithms

> Attackers can bypass channel-binding protections in PostgreSQL JDBC connections by triggering a silent authentication downgrade, enabling man-in-the-middle attacks.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jul 2026
- **Updated:** 6 Jul 2026
- **Also known as:** BIT-postgresql-jdbc-driver-2026-54291, CLEANSTART-2026-EP87494, CLEANSTART-2026-KV94279, CLEANSTART-2026-WV63281, CLEANSTART-2026-XF69190, CLEANSTART-2026-ZS37563, DEBIAN-CVE-2026-54291, ECHO-96c6-986e-d7f0, GHSA-j92g-9f8w-j867, MINI-46f5-mcrg-678f, MINI-4mgp-gg4j-pm63, MINI-4mjh-4jpp-rv53, MINI-57m8-j52p-3jp3, MINI-63pg-ww5w-wh24, MINI-6jr6-v7g5-8x9c, MINI-7cc2-826r-p24w, MINI-9mc6-hfq4-59wq, MINI-9r3p-x7hq-rr6j, MINI-c25p-w8qc-qwj2, MINI-fmj6-389f-g4cr, MINI-m9cm-3q73-vh53, MINI-mc72-x8cf-877c, MINI-mpqj-r28h-w78r, MINI-mqh2-7fpq-87gx, MINI-mrf8-9xgx-mfmm, MINI-qmrj-rj7m-32jm, MINI-r4rh-2jcf-48j4, MINI-w3p3-87rm-573j, MINI-x5m6-59rf-r43c, MINI-xjgh-43v6-xfrx, ROOT-APP-MAVEN-CVE-2026-54291, UBUNTU-CVE-2026-54291

## What is CVE-2026-54291?

CVE-2026-54291 is a high-severity vulnerability in pgjdbc, published on 6 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

pgjdbc is an open source postgresql JDBC Driver. In releases 42.7.4 through 42.7.11, channelBinding=require connections can be silently downgraded from SCRAM-SHA-256-PLUS with channel binding to plain SCRAM-SHA-256 without it, losing the man-in-the-middle protection the setting is meant to guarantee. An attacker who can intercept the TLS connection can trigger the downgrade with a certificate whose signature algorithm has no tls-server-end-point channel-binding hash, because the bundled com.ongres.scram:scram-client returns an empty byte array instead of failing and pgJDBC ScramAuthenticator checks only that the server advertised a PLUS mechanism, without rejecting the empty binding or checking that the negotiated mechanism uses channel binding. This issue is fixed in version 42.7.12.

Weakness: CWE-757 (Selection of Less-Secure Algorithm During Negotiation), CWE-636 (Not Failing Securely)

## Which versions are affected by CVE-2026-54291?

3 open source packages ship an affected version, including org.postgresql:postgresql and postgresql-jdbc-driver. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.postgresql:postgresql` | Maven | From 42.7.4 | 42.7.12 |
| `org.postgresql:postgresql` | Maven | From 42.7.4 | 42.7.12 |
| `postgresql-jdbc-driver` | Bitnami | From 42.7.4 | 42.7.12 |

Products: Postgresql Postgresql Jdbc Driver.

## How do I fix CVE-2026-54291?

Upgrade org.postgresql:postgresql to 42.7.12 or later.

## Is CVE-2026-54291 being exploited?

There is no known exploitation of CVE-2026-54291 in the wild and no public exploit code.

## Other vulnerabilities in pgjdbc

- [CVE-2025-49146](https://insights.sbomify.com/CVE-2025-49146/): pgjdbc Client Allows Fallback to Insecure Authentication Despite channelBinding=require Configuration (high 8.2)
- [CVE-2018-10936](https://insights.sbomify.com/CVE-2018-10936/): Moderate severity vulnerability that affects org.postgresql:pgjdbc-aggregate (high 8.1)
- [CVE-2026-42198](https://insights.sbomify.com/CVE-2026-42198/): pgjdbc: Unbounded PBKDF2 iterations in SCRAM authentication allows CPU exhaustion DoS (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54291 and fix it if it is affected.

What it is: CVE-2026-54291 is a high-severity vulnerability in pgjdbc, published on 6 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-54291 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.postgresql:postgresql (Maven): affected from 42.7.4; fixed in 42.7.12
- org.postgresql:postgresql (Maven): affected from 42.7.4; fixed in 42.7.12
- postgresql-jdbc-driver (Bitnami): affected from 42.7.4; fixed in 42.7.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54291/ (Markdown: https://insights.sbomify.com/CVE-2026-54291/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54291
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54291
- OSV: https://osv.dev/vulnerability/CVE-2026-54291

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54291/
Summaries are generated and may contain mistakes; the official description above is the record.
