# CVE-2026-54300: @astrojs/netlify broadens Astro image.remotePatterns in Netlify Image CDN config

> The Astro Netlify adapter incorrectly converts image remote patterns, allowing Server-Side Request Forgery by matching unintended hosts and paths.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jun 2026
- **Updated:** 23 Jun 2026
- **Also known as:** GHSA-529g-xq4f-cw38

## What is CVE-2026-54300?

CVE-2026-54300 is a medium-severity server-side request forgery vulnerability in withastro astro, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

@astrojs/netlify is an adapter that allows Astro to deploy your hybrid or server rendered site to Netlify. Prior to 7.0.13, @astrojs/netlify converts Astro image.remotePatterns into Netlify Image CDN images.remote_images regular expressions with broader semantics than Astro's canonical matcher. A single wildcard hostname such as *.example.com is converted to an optional subdomain regex, so the apex host matches. A single wildcard pathname such as /ok/* is converted without end anchoring, so deeper paths match by prefix. This vulnerability is fixed in 7.0.13.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-54300?

2 open source packages ship an affected version, including @astrojs/netlify.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@astrojs/netlify` | npm | All versions | 7.0.13 |
| `@astrojs/netlify` | npm | All versions | 7.0.13 |

## How do I fix CVE-2026-54300?

Upgrade @astrojs/netlify to 7.0.13 or later.

## Is CVE-2026-54300 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54300 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54300 and fix it if it is affected.

What it is: CVE-2026-54300 is a medium-severity server-side request forgery vulnerability in withastro astro, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54300 exists.

Affected packages and fixed versions:
- @astrojs/netlify (npm): affected all versions; fixed in 7.0.13
- @astrojs/netlify (npm): affected all versions; fixed in 7.0.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54300/ (Markdown: https://insights.sbomify.com/CVE-2026-54300/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54300
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54300
- OSV: https://osv.dev/vulnerability/CVE-2026-54300

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54300/
Summaries are generated and may contain mistakes; the official description above is the record.
