CVE-2026-54304 n8n: SecurityScorecard Node Leaks API Token to User-Controlled Host
An authenticated user can configure a node to send API tokens to an attacker-controlled host, bypassing domain restrictions and leaking credentials.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-54304?
CVE-2026-54304 is a high-severity server-side request forgery vulnerability in N8n N8n, published on 23 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
n8n is an open source workflow automation platform. Prior to 1.123.55, 2.25.7, and 2.26.1, an authenticated user with permission to create or modify workflows and access to a SecurityScorecard credential with limited allowed domains could configure the SecurityScorecard node's report download operation to target an attacker-controlled URL. The node attached the SecurityScorecard API token to the outbound request, causing the credential to be sent to the attacker-controlled host bypassing credential configured limitations and exfiltrating. This vulnerability is fixed in 1.123.55, 2.25.7, and 2.26.1.
Weakness: CWE-200
Which versions are affected by CVE-2026-54304?
6 open source packages ship an affected version, including n8n. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
n8n npm | All versions | 1.123.55 |
n8n npm | All versions | 1.123.55 |
n8n npm | From 2.0.0-rc.0 | 2.25.7 |
n8n npm | From 2.0.0-rc.0 | 2.25.7 |
n8n npm | From 2.26.0 | 2.26.1 |
n8n npm | From 2.26.0 | 2.26.1 |
Products include N8n N8n.
How do I fix CVE-2026-54304?
Upgrade n8n to a fixed version for your release line: 1.123.55, 2.25.7 or 2.26.1.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2026-54304 being exploited?
There is no known exploitation of CVE-2026-54304 in the wild and no public exploit code.
Other vulnerabilities in N8n N8n
- CVE-2025-68613 n8n Improper Control of Dynamically-Managed Code Resources
- CVE-2026-21877 n8n is vulnerable to Remote Code Execution via Arbitrary File Write
- CVE-2026-21858 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling
- CVE-2026-1470 n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution
- CVE-2025-68668 n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node
Sources
Also known as GHSA-rm2v-h48j-895m, MINI-644w-2284-pxfx, ROOT-APP-NPM-CVE-2026-54304.