CVE-2026-54305 n8n: Cross-Tenant Credential Takeover via Dynamic Credentials EE Endpoints
Authenticated users can hijack other users' OAuth credentials via Dynamic Credentials endpoints, enabling data exfiltration and persistent integration takeover.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-54305?
CVE-2026-54305 is a high-severity missing authorization vulnerability in N8n N8n, published on 23 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
n8n is an open source workflow automation platform. Prior to 1.123.55, 2.25.7, and 2.26.2, three EE endpoints used by the Dynamic Credentials feature accepted any authenticated n8n session without performing per-resource ownership or scope checks on the target workflow or credential. An authenticated user with no project membership or credential sharing relationship could enumerate credential identifiers, names, and types referenced by any private workflow in the instance, initiate an OAuth authorization flow against another user's credential to overwrite its stored tokens with tokens bound to an account they control, or revoke another user's stored credential tokens entirely. Workflows relying on a hijacked credential would subsequently execute under the attacker's OAuth identity, enabling data exfiltration to attacker-controlled external services and persistent takeover of integrations. Token revocation would break affected workflows. This vulnerability is fixed in 1.123.55, 2.25.7, and 2.26.2.
Which versions are affected by CVE-2026-54305?
6 open source packages ship an affected version, including n8n. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
n8n npm | All versions | 1.123.55 |
n8n npm | All versions | 1.123.55 |
n8n npm | From 2.0.0-rc.0 | 2.25.7 |
n8n npm | From 2.0.0-rc.0 | 2.25.7 |
n8n npm | From 2.26.0 | 2.26.2 |
n8n npm | From 2.26.0 | 2.26.2 |
Products include N8n N8n.
How do I fix CVE-2026-54305?
Upgrade n8n to a fixed version for your release line: 1.123.55, 2.25.7 or 2.26.2.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-54305 being exploited?
There is no known exploitation of CVE-2026-54305 in the wild and no public exploit code.
Other vulnerabilities in N8n N8n
- CVE-2025-68613 n8n Improper Control of Dynamically-Managed Code Resources
- CVE-2026-21877 n8n is vulnerable to Remote Code Execution via Arbitrary File Write
- CVE-2026-21858 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling
- CVE-2026-1470 n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution
- CVE-2025-68668 n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node
Sources
Also known as GHSA-2j5h-858j-5mpf, MINI-g3m2-7jp2-28qj, ROOT-APP-NPM-CVE-2026-54305.