CVE-2026-54307 n8n: Credential Exfiltration via Permission Bypass
A member-level user with editor access can exfiltrate credentials they do not own via public API endpoints due to incomplete ownership checks.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-54307?
CVE-2026-54307 is a high-severity missing authorization vulnerability in N8n N8n, published on 23 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
n8n is an open source workflow automation platform. Prior to 1.123.55, 2.25.7, and 2.26.2, a member-level user with editor access to a shared workflow could reference credentials they do not own via specific public API endpoints. Credential ownership checks were only enforced partially leading to cross-user credential access. This issue affects instances where workflow sharing is enabled and at least one workflow has been shared with a member-level user as an Editor. This vulnerability is fixed in 1.123.55, 2.25.7, and 2.26.2.
Weakness: CWE-863
Which versions are affected by CVE-2026-54307?
6 open source packages ship an affected version, including n8n. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
n8n npm | All versions | 1.123.55 |
n8n npm | All versions | 1.123.55 |
n8n npm | From 2.0.0-rc.0 | 2.25.7 |
n8n npm | From 2.0.0-rc.0 | 2.25.7 |
n8n npm | From 2.26.0 | 2.26.2 |
n8n npm | From 2.26.0 | 2.26.2 |
Products include N8n N8n.
How do I fix CVE-2026-54307?
Upgrade n8n to a fixed version for your release line: 1.123.55, 2.25.7 or 2.26.2.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-54307 being exploited?
There is no known exploitation of CVE-2026-54307 in the wild and no public exploit code.
Other vulnerabilities in N8n N8n
- CVE-2025-68613 n8n Improper Control of Dynamically-Managed Code Resources
- CVE-2026-21877 n8n is vulnerable to Remote Code Execution via Arbitrary File Write
- CVE-2026-21858 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling
- CVE-2026-1470 n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution
- CVE-2025-68668 n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node
Sources
Also known as GHSA-pmqw-72cg-wx85, MINI-3466-98jh-m923, ROOT-APP-NPM-CVE-2026-54307.