# CVE-2026-54309: n8n: n8n MCP Browser HTTP Transport Exposes Unauthenticated Browser-Control Sessions

> Unauthenticated attackers can control the user's browser via the MCP HTTP transport, enabling JavaScript execution and data theft.

- **Severity:** High 8.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:H/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jun 2026
- **Updated:** 23 Jun 2026
- **Also known as:** GHSA-qrx8-25qr-5r7v, MINI-cgqc-j2v7-46qf, ROOT-APP-NPM-CVE-2026-54309

## What is CVE-2026-54309?

CVE-2026-54309 is a high-severity missing authorization vulnerability in N8n N8n, published on 23 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

n8n is an open source workflow automation platform. Prior to 2.25.7 and 2.26.2, when @n8n/mcp-browser is run in HTTP transport mode, the MCP endpoint accepts session initialization and tool invocation requests without any authentication. Any network-reachable client, or any website visited by the user, can establish an MCP session and invoke browser-control tools. Where the n8n AI Browser Bridge extension is installed and a browser connection is active, an unauthenticated caller can access browser-control capabilities including navigation, JavaScript evaluation, and cookie and storage access against the user's real browser profile. This issue only affects instances where @n8n/mcp-browser is run with the HTTP transport (--transport http). This vulnerability is fixed in 2.25.7 and 2.26.2.

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2026-54309?

4 open source packages ship an affected version, including n8n. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `n8n` | npm | All versions | 2.25.7 |
| `n8n` | npm | All versions | 2.25.7 |
| `n8n` | npm | From 2.26.0 | 2.26.2 |
| `n8n` | npm | From 2.26.0 | 2.26.2 |

Products: N8n N8n.

## How do I fix CVE-2026-54309?

Upgrade n8n to a fixed version for your release line: 2.25.7 or 2.26.2.

## Is CVE-2026-54309 being exploited?

There is no known exploitation of CVE-2026-54309 in the wild and no public exploit code.

## Other vulnerabilities in N8n N8n

- [CVE-2025-68613](https://insights.sbomify.com/CVE-2025-68613/): n8n Improper Control of Dynamically-Managed Code Resources (critical 10.0, exploited in the wild)
- [CVE-2026-21877](https://insights.sbomify.com/CVE-2026-21877/): n8n is vulnerable to Remote Code Execution via Arbitrary File Write (critical 10.0)
- [CVE-2026-21858](https://insights.sbomify.com/CVE-2026-21858/): n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling (critical 10.0)
- [CVE-2026-1470](https://insights.sbomify.com/CVE-2026-1470/): n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution (critical 9.9)
- [CVE-2025-68668](https://insights.sbomify.com/CVE-2025-68668/): n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54309 and fix it if it is affected.

What it is: CVE-2026-54309 is a high-severity missing authorization vulnerability in N8n N8n, published on 23 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-54309 in the wild and no public exploit code.

Affected packages and fixed versions:
- n8n (npm): affected all versions; fixed in 2.25.7
- n8n (npm): affected all versions; fixed in 2.25.7
- n8n (npm): affected from 2.26.0; fixed in 2.26.2
- n8n (npm): affected from 2.26.0; fixed in 2.26.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54309/ (Markdown: https://insights.sbomify.com/CVE-2026-54309/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54309
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54309
- OSV: https://osv.dev/vulnerability/CVE-2026-54309

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54309/
Summaries are generated and may contain mistakes; the official description above is the record.
