CVE-2026-54310 n8n: SQL Injection in Postgres v1/TimesclaeDB Nodes
Authenticated users can inject arbitrary SQL into Postgres or TimescaleDB nodes, allowing unauthorized database access and modification.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-54310?
CVE-2026-54310 is a medium-severity SQL injection vulnerability in N8n N8n, published on 23 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
n8n is an open source workflow automation platform. Prior to 2.25.7 and 2.26.2, an authenticated user with permission to create or modify workflows could supply a crafted parameters to the TimescaleDB and/or legacy Postgres v1 node's allowing arbitrary SQL to be injected and executed against the connected database within the privileges of the configured database account. This vulnerability is fixed in 2.25.7 and 2.26.2.
Weakness: CWE-89
Which versions are affected by CVE-2026-54310?
4 open source packages ship an affected version, including n8n. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
n8n npm | All versions | 2.25.7 |
n8n npm | All versions | 2.25.7 |
n8n npm | From 2.26.0 | 2.26.2 |
n8n npm | From 2.26.0 | 2.26.2 |
Products include N8n N8n.
How do I fix CVE-2026-54310?
Upgrade n8n to a fixed version for your release line: 2.25.7 or 2.26.2.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2026-54310 being exploited?
There is no known exploitation of CVE-2026-54310 in the wild and no public exploit code.
Other vulnerabilities in N8n N8n
- CVE-2025-68613 n8n Improper Control of Dynamically-Managed Code Resources
- CVE-2026-21877 n8n is vulnerable to Remote Code Execution via Arbitrary File Write
- CVE-2026-21858 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling
- CVE-2026-1470 n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution
- CVE-2025-68668 n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node
Sources
Also known as GHSA-c37g-w77q-m4vp, MINI-q8pj-gxxg-qwv9, ROOT-APP-NPM-CVE-2026-54310.