# CVE-2026-54314: n8n: Denial of Service via ZIP decompression in webhook workflow

> An unauthenticated attacker can cause a denial of service in n8n by sending a malicious compressed archive to a webhook workflow, exhausting memory.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jun 2026
- **Updated:** 24 Jun 2026
- **Also known as:** GHSA-jqpw-qww5-cj4c, MINI-cv92-8jjv-rgqv, ROOT-APP-NPM-CVE-2026-54314

## What is CVE-2026-54314?

CVE-2026-54314 is a medium-severity denial of service vulnerability in N8n N8n, published on 23 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

n8n is an open source workflow automation platform. Prior to 2.24.0, the Compression node's Decompress operation expanded attacker-controlled archives into memory without enforcing limits on decompressed output size. An unauthenticated attacker could send a small compressed archive to a public webhook workflow using this node, causing the n8n process to terminate due to memory exhaustion and disrupting all workflows in the same instance. This vulnerability is fixed in 2.24.0.

Weakness: CWE-409 (Improper Handling of Highly Compressed Data (Data Amplification))

## Which versions are affected by CVE-2026-54314?

2 open source packages ship an affected version, including n8n. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `n8n` | npm | All versions | 2.24.0 |
| `n8n` | npm | All versions | 2.24.0 |

Products: N8n N8n.

## How do I fix CVE-2026-54314?

Upgrade n8n to 2.24.0 or later.

## Is CVE-2026-54314 being exploited?

There is no known exploitation of CVE-2026-54314 in the wild and no public exploit code.

## Other vulnerabilities in N8n N8n

- [CVE-2025-68613](https://insights.sbomify.com/CVE-2025-68613/): n8n Improper Control of Dynamically-Managed Code Resources (critical 10.0, exploited in the wild)
- [CVE-2026-21877](https://insights.sbomify.com/CVE-2026-21877/): n8n is vulnerable to Remote Code Execution via Arbitrary File Write (critical 10.0)
- [CVE-2026-21858](https://insights.sbomify.com/CVE-2026-21858/): n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling (critical 10.0)
- [CVE-2026-1470](https://insights.sbomify.com/CVE-2026-1470/): n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution (critical 9.9)
- [CVE-2025-68668](https://insights.sbomify.com/CVE-2025-68668/): n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54314 and fix it if it is affected.

What it is: CVE-2026-54314 is a medium-severity denial of service vulnerability in N8n N8n, published on 23 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-54314 in the wild and no public exploit code.

Affected packages and fixed versions:
- n8n (npm): affected all versions; fixed in 2.24.0
- n8n (npm): affected all versions; fixed in 2.24.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54314/ (Markdown: https://insights.sbomify.com/CVE-2026-54314/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54314
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54314
- OSV: https://osv.dev/vulnerability/CVE-2026-54314

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54314/
Summaries are generated and may contain mistakes; the official description above is the record.
