# CVE-2026-54316: Claude Code: Out-of-Band Data Exfiltration via Pre-Approved HuggingFace Domain in WebFetch

> Attackers can exfiltrate sensitive data via covert HTTP requests to pre-approved domains, requiring an upgrade to Claude Code.

- **Severity:** Medium 6.0 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Jun 2026
- **Updated:** 23 Jun 2026
- **Also known as:** GHSA-fg94-h982-f3mm, MINI-2vgr-mc8g-4vxq, MINI-4q54-qrh3-qvgv

## What is CVE-2026-54316?

CVE-2026-54316 is a medium-severity vulnerability in anthropics claude-code, published on 23 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Claude Code is an agentic coding tool.  From 0.2.54 until 2.1.163, because the hostname huggingface.co was pre-approved as a bare hostname for the WebFetch tool, any path on that domain—including attacker-controlled model repositories—was auto-approved without a permission prompt or being subject to --allowedTools restrictions. An attacker able to inject untrusted content into a Claude Code context could direct it to issue WebFetch requests against attacker-controlled repository files (e.g. /resolve/main/config.json), which HuggingFace counts as downloads server-side, creating a covert out-of-band channel for encoding and exfiltrating data Claude can access such as files, environment variables, or command output. Reliably exploiting this required the ability to add untrusted content into a Claude Code context window. This vulnerability is fixed in 2.1.163.

Weakness: CWE-515 (Covert Storage Channel), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor), CWE-183 (Permissive List of Allowed Inputs)

## Which versions are affected by CVE-2026-54316?

2 open source packages ship an affected version, including @anthropic-ai/claude-code. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@anthropic-ai/claude-code` | npm | From 0.2.54 | 2.1.163 |
| `@anthropic-ai/claude-code` | npm | From 0.2.54 | 2.1.163 |

Products: Anthropic Claude Code.

## How do I fix CVE-2026-54316?

Upgrade @anthropic-ai/claude-code to 2.1.163 or later.

## Is CVE-2026-54316 being exploited?

There is no known exploitation of CVE-2026-54316 in the wild and no public exploit code.

Public exploit code:

- Reproduction lab for CVE-2026-54316 (Claude Code WebFetch huggingface.co bare-hostname permission bypass / exfiltration) (github_poc): https://github.com/InertFluid/cve-2026-54316-lab

## Other vulnerabilities in anthropics claude-code

- [CVE-2025-66032](https://insights.sbomify.com/CVE-2025-66032/): Claude Code Command Validation Bypass Allows Arbitrary Code Execution (high 8.7)
- [CVE-2025-64755](https://insights.sbomify.com/CVE-2025-64755/): @anthropic-ai/claude-code has Sed Command Validation Bypass that Allows Arbitrary File Writes (high 8.7)
- [CVE-2025-59536](https://insights.sbomify.com/CVE-2025-59536/): Claude Code's startup trust dialog could lead to Command Execution attack (high 8.7)
- [CVE-2025-58764](https://insights.sbomify.com/CVE-2025-58764/): Claude Code rg command had Command Injection that allowed bypass of user approval prompt for command execution (high 8.7)
- [CVE-2025-59041](https://insights.sbomify.com/CVE-2025-59041/): Claude Code vulnerable to arbitrary code execution caused by maliciously configured git email (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54316 and fix it if it is affected.

What it is: CVE-2026-54316 is a medium-severity vulnerability in anthropics claude-code, published on 23 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-54316 in the wild and no public exploit code.

Affected packages and fixed versions:
- @anthropic-ai/claude-code (npm): affected from 0.2.54; fixed in 2.1.163
- @anthropic-ai/claude-code (npm): affected from 0.2.54; fixed in 2.1.163

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54316/ (Markdown: https://insights.sbomify.com/CVE-2026-54316/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54316
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54316
- OSV: https://osv.dev/vulnerability/CVE-2026-54316

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54316/
Summaries are generated and may contain mistakes; the official description above is the record.
