# CVE-2026-54325: Pi loads project-local extensions without approval

> Attackers can execute arbitrary code by placing malicious extensions in a repository, which Pi loads automatically without user approval.

- **Severity:** Medium 4.4 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Jun 2026
- **Updated:** 23 Jun 2026
- **Also known as:** GHSA-mqxh-6gq7-558m, MINI-qqx2-vrr2-38pg

## What is CVE-2026-54325?

CVE-2026-54325 is a medium-severity code injection vulnerability in earendil-works pi, published on 23 Jun 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Pi is a minimal terminal coding harness. Pi before 0.79.0 loaded project-local configuration and resources from a repository's .pi directory without first asking the user to trust that repository. This included project-local extensions, which are executable TypeScript or JavaScript modules loaded into the Pi process. An attacker who controls a repository could place Pi-specific project resources in that repository. If a user then started Pi from that working tree, the project-local extension code could run with the same privileges as the local Pi process without the user having a convenient way to make a trust decision. This vulnerability is fixed in 0.79.0.

Weakness: CWE-829 (Inclusion of Functionality from Untrusted Control Sphere)

## Which versions are affected by CVE-2026-54325?

2 open source packages ship an affected version, including @earendil-works/pi-coding-agent.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@earendil-works/pi-coding-agent` | npm | All versions | 0.79.0 |
| `@earendil-works/pi-coding-agent` | npm | All versions | 0.79.0 |

## How do I fix CVE-2026-54325?

Upgrade @earendil-works/pi-coding-agent to 0.79.0 or later.

## Is CVE-2026-54325 being exploited?

There is no known exploitation of CVE-2026-54325 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54325 and fix it if it is affected.

What it is: CVE-2026-54325 is a medium-severity code injection vulnerability in earendil-works pi, published on 23 Jun 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-54325 in the wild and no public exploit code.

Affected packages and fixed versions:
- @earendil-works/pi-coding-agent (npm): affected all versions; fixed in 0.79.0
- @earendil-works/pi-coding-agent (npm): affected all versions; fixed in 0.79.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54325/ (Markdown: https://insights.sbomify.com/CVE-2026-54325/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54325
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54325
- OSV: https://osv.dev/vulnerability/CVE-2026-54325

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54325/
Summaries are generated and may contain mistakes; the official description above is the record.
