{"answers":{"affected":"4 open source packages ship an affected version, including @earendil-works/pi-coding-agent and @mariozechner/pi-coding-agent.","exploited":"There is no known exploitation of CVE-2026-54326 in the wild and no public exploit code.","fix":"Upgrade @earendil-works/pi-coding-agent to 0.78.1 or later.","what":"CVE-2026-54326 is a low-severity cross-site scripting vulnerability in earendil-works pi, published on 23 Jun 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-54326 and fix it if it is affected.\n\nWhat it is: CVE-2026-54326 is a low-severity cross-site scripting vulnerability in earendil-works pi, published on 23 Jun 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-54326 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @earendil-works/pi-coding-agent (npm): affected from 0.74.0; fixed in 0.78.1\n- @earendil-works/pi-coding-agent (npm): affected from 0.74.0; fixed in 0.78.1\n- @mariozechner/pi-coding-agent (npm): affected from 0.27.5 up to 0.73.1; no fix listed\n- @mariozechner/pi-coding-agent (npm): affected from 0.27.5 up to 0.73.1; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-54326/ (Markdown: https://insights.sbomify.com/CVE-2026-54326/index.md)","id":"CVE-2026-54326","markdown":"https://insights.sbomify.com/CVE-2026-54326/index.md","name":"CVE-2026-54326","record":{"aliases":["GHSA-7v5m-pr3q-6453","MINI-gc3h-mgpf-54f6"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Terminal coding harness","requires_auth":"none","summary":"Attackers can execute arbitrary scripts in victims' browsers by exploiting a Markdown URL sanitization bypass in Pi's HTML session exports.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":2.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Pi is a minimal terminal coding harness. From 0.74.0 until 0.78.1, Pi HTML exports render session Markdown into a static HTML file. It did not consistently reject unsafe Markdown link and image URL schemes. In versions with scheme filtering, C0 control characters in the URL scheme could bypass the check because browsers normalize those characters before navigation. This vulnerability is fixed in 0.78.1.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Pi: Potential XSS in HTML session exports via Markdown URL sanitization bypass","id":"CVE-2026-54326","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":4,"n_references":3,"next":{"headline":"Pi: Race condition in auth.json writes could expose stored credentials","id":"CVE-2026-54327"},"packages":[{"ecosystem":"npm","fixed":["0.78.1"],"introduced":["0.74.0"],"last_affected":[],"package":"@earendil-works/pi-coding-agent","purl":null,"source":"GHSA-7v5m-pr3q-6453"},{"ecosystem":"npm","fixed":["0.78.1"],"introduced":["0.74.0"],"last_affected":[],"package":"@earendil-works/pi-coding-agent","purl":"pkg:npm/%40earendil-works/pi-coding-agent","source":"GHSA-7v5m-pr3q-6453"},{"ecosystem":"npm","fixed":[],"introduced":["0.27.5"],"last_affected":["0.73.1"],"package":"@mariozechner/pi-coding-agent","purl":null,"source":"GHSA-7v5m-pr3q-6453"},{"ecosystem":"npm","fixed":[],"introduced":["0.27.5"],"last_affected":["0.73.1"],"package":"@mariozechner/pi-coding-agent","purl":"pkg:npm/%40mariozechner/pi-coding-agent","source":"GHSA-7v5m-pr3q-6453"}],"prev":{"headline":"Pi loads project-local extensions without approval","id":"CVE-2026-54325"},"products":["pi"],"published":"2026-06-23","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-06-24","vendors":["earendil-works"]},"summary":"Attackers can execute arbitrary scripts in victims' browsers by exploiting a Markdown URL sanitization bypass in Pi's HTML session exports.","url":"https://insights.sbomify.com/CVE-2026-54326/"}