CVE-2026-54327 Pi: Race condition in auth.json writes could expose stored credentials
A race condition in Pi's credential storage allows local attackers to read API keys and OAuth tokens during file write operations.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-54327?
CVE-2026-54327 is a low-severity vulnerability in earendil-works pi, published on 23 Jun 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
Pi is a minimal terminal coding harness. From 0.74.0 until 0.78.1, Pi stored API keys and OAuth credentials in auth.json. A race condition in the file write path could briefly create or rewrite this file with permissions derived from the process umask before tightening the file to owner-only permissions. This vulnerability is fixed in 0.78.1.
Which versions are affected by CVE-2026-54327?
4 open source packages ship an affected version, including @earendil-works/pi-coding-agent and @mariozechner/pi-coding-agent.
| Package | Affected | Fixed in |
|---|---|---|
@earendil-works/pi-coding-agent npm | From 0.74.0 | 0.78.1 |
@earendil-works/pi-coding-agent npm | From 0.74.0 | 0.78.1 |
@mariozechner/pi-coding-agent npm | From 0.28.0 to 0.73.1 | None |
@mariozechner/pi-coding-agent npm | From 0.28.0 to 0.73.1 | None |
How do I fix CVE-2026-54327?
Upgrade @earendil-works/pi-coding-agent to 0.78.1 or later.
Is CVE-2026-54327 being exploited?
There is no known exploitation of CVE-2026-54327 in the wild and no public exploit code.
Sources
Also known as GHSA-r95r-rj6r-c39x, MINI-6cq8-pppp-94wq.