CVE-2026-54328 Pi: Predictable temporary extension install paths allow local privilege escalation on shared Linux hosts
Local attackers can execute arbitrary code in victim processes by pre-creating predictable temporary extension paths on shared Linux hosts.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-54328?
CVE-2026-54328 is a high-severity vulnerability in earendil-works pi, published on 23 Jun 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
Pi is a minimal terminal coding harness. From 0.74.0 until 0.78.1, Pi versions with temporary npm or git extension package installs used predictable paths under the operating system temporary directory. On Linux-based multi-user systems, a local attacker who can write to the shared temporary directory could prepare the expected package location before another user runs pi with a temporary extension package source. Pi could then load attacker-controlled extension code in the victim user's process. This vulnerability is fixed in 0.78.1.
Weakness: CWE-379
Which versions are affected by CVE-2026-54328?
4 open source packages ship an affected version, including @earendil-works/pi-coding-agent and @mariozechner/pi-coding-agent.
| Package | Affected | Fixed in |
|---|---|---|
@earendil-works/pi-coding-agent npm | From 0.74.0 | 0.78.1 |
@earendil-works/pi-coding-agent npm | From 0.74.0 | 0.78.1 |
@mariozechner/pi-coding-agent npm | From 0.50.0 to 0.73.1 | None |
@mariozechner/pi-coding-agent npm | From 0.50.0 to 0.73.1 | None |
How do I fix CVE-2026-54328?
Upgrade @earendil-works/pi-coding-agent to 0.78.1 or later.
Is CVE-2026-54328 being exploited?
There is no known exploitation of CVE-2026-54328 in the wild and no public exploit code.
Sources
Also known as GHSA-jfgx-wxx8-mp94, MINI-qrc4-qxgr-hgmx.