# CVE-2026-54341: Dragonfly: RESTORE operations may crash the server

> An unauthenticated remote attacker can crash the DragonflyDB server by sending a crafted RESTORE command, causing a denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 26 Jun 2026
- **Updated:** 26 Jun 2026
- **Also known as:** GHSA-cwjr-j869-h8q9

## What is CVE-2026-54341?

CVE-2026-54341 is a high-severity denial of service vulnerability in dragonflydb dragonfly, published on 26 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Dragonfly is an in-memory data store built for modern application workloads. Prior to 1.39.0, a crafted RESTORE payload triggers an out-of-bounds read in DragonflyDB's listpack collection loaders, crashing the entire server process (SIGSEGV). Because DragonflyDB requires no authentication by default and RESTORE is a normal keyspace command, an unauthenticated remote attacker can crash the server with a single ~24-byte command — a remote, repeatable denial of service. This vulnerability is fixed in 1.39.0.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2026-54341?


## How do I fix CVE-2026-54341?

No fix has been published for CVE-2026-54341 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-54341 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54341 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54341 and fix it if it is affected.

What it is: CVE-2026-54341 is a high-severity denial of service vulnerability in dragonflydb dragonfly, published on 26 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54341 exists.

Affected product: dragonflydb dragonfly. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54341/ (Markdown: https://insights.sbomify.com/CVE-2026-54341/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54341
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54341
- OSV: https://osv.dev/vulnerability/CVE-2026-54341

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54341/
Summaries are generated and may contain mistakes; the official description above is the record.
