# CVE-2026-54343: Frappe LMS: Path Traversal in SCORM File Serving

> A remote attacker can read arbitrary files outside the SCORM directory via path traversal in Frappe LMS.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 17 Sep 2026
- **Updated:** 18 Sep 2026
- **Also known as:** GHSA-3mq2-3c8v-m92j

## What is CVE-2026-54343?

CVE-2026-54343 is a high-severity path traversal vulnerability in frappe lms, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Frappe Learning Management System (LMS) is a learning system that helps users structure their content. Prior to version 2.52.1, a remote attacker can request a traversal path handled by SCORMRenderer.render in lms/page_renderers.py. The renderer constructs and opens a server-side path without first confirming that its real path remains within public/scorm, allowing files outside the SCORM directory to be read when they are accessible to the server process. This issue is fixed in version 2.52.1.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-54343?


## How do I fix CVE-2026-54343?

No fix has been published for CVE-2026-54343 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-54343 being exploited?

There is no known exploitation of CVE-2026-54343 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54343 and fix it if it is affected.

What it is: CVE-2026-54343 is a high-severity path traversal vulnerability in frappe lms, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-54343 in the wild and no public exploit code.

Affected product: frappe lms. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54343/ (Markdown: https://insights.sbomify.com/CVE-2026-54343/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54343
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54343
- OSV: https://osv.dev/vulnerability/CVE-2026-54343

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54343/
Summaries are generated and may contain mistakes; the official description above is the record.
