# CVE-2026-54347: Froxlor: Stored XSS in DNS TXT Record Content Allows Customer-to-Admin Account Takeover

> An authenticated customer can inject JavaScript into DNS TXT records, leading to admin account takeover when the admin views the configuration.

- **Severity:** High 8.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Aug 2026
- **Updated:** 19 Aug 2026
- **Also known as:** GHSA-43gm-9rr3-cx7g

## What is CVE-2026-54347?

CVE-2026-54347 is a high-severity cross-site scripting vulnerability in froxlor, published on 18 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Froxlor is open source server administration software. Prior to 2.3.8, DNS TXT record content accepted by lib/Froxlor/Api/Commands/DomainZones.php can contain HTML special characters, lib/Froxlor/UI/Callbacks/Text.php returns the content from Text::wordwrap without HTML escaping, and templates/Froxlor/table/table.html.twig renders the callback result with the raw filter. An authenticated customer with DNS editor access can store JavaScript-bearing content in a TXT record. When an administrator views the affected domain's DNS configuration, the payload executes automatically in the administrator's browser session, which can expose session data or perform privileged panel actions. This issue is fixed in version 2.3.8.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-54347?

2 open source packages ship an affected version, including froxlor/froxlor.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `froxlor/froxlor` | Packagist | All versions | 2.3.8 |
| `froxlor/froxlor` | Packagist | All versions | 2.3.8 |

## How do I fix CVE-2026-54347?

Upgrade froxlor/froxlor to 2.3.8 or later.

## Is CVE-2026-54347 being exploited?

There is no known exploitation of CVE-2026-54347 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54347 and fix it if it is affected.

What it is: CVE-2026-54347 is a high-severity cross-site scripting vulnerability in froxlor, published on 18 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-54347 in the wild and no public exploit code.

Affected packages and fixed versions:
- froxlor/froxlor (Packagist): affected all versions; fixed in 2.3.8
- froxlor/froxlor (Packagist): affected all versions; fixed in 2.3.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54347/ (Markdown: https://insights.sbomify.com/CVE-2026-54347/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54347
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54347
- OSV: https://osv.dev/vulnerability/CVE-2026-54347

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54347/
Summaries are generated and may contain mistakes; the official description above is the record.
