# CVE-2026-54352: Budibase: Arbitrary file read by workspace-builder via PWA-zip symlink upload

> A workspace builder can read arbitrary server files by uploading a zip containing symlinks, bypassing path validation checks.

- **Severity:** Critical 9.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Jun 2026
- **Updated:** 27 Jun 2026
- **Also known as:** GHSA-w7mq-r738-x278

## What is CVE-2026-54352?

CVE-2026-54352 is a critical path traversal vulnerability in budibase, published on 26 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Budibase is an open-source low-code platform. Prior to 3.39.9, `POST /api/pwa/process-zip` at packages/server/src/api/routes/static.ts:24 accepts a builder-uploaded .zip, extracts it with extract-zip@2.0.1 into a temp directory, then for each entry listed in icons.json validates the icon path, opens it, and streams the bytes into MinIO. The resulting object is served back via GET /api/assets/{appId}/pwa/{uuid}.png. extract-zip@2.0.1 preserves absolute symlink targets when restoring symlink entries. The icon-source validator at packages/server/src/api/controllers/static/index.ts:259-268 resolves the icon source string against baseDir (path.resolve), checks resolvedSrc.startsWith(baseDir + path.sep) against that string, and calls fs.existsSync(resolvedSrc) which follows symbolic links to confirm the target exists. None of the three calls reject symbolic-link entries. packages/backend-core/src/objectStore/objectStore.ts:302 then calls (await fsp.open(path)).createReadStream() on the resolved path. fsp.open follows the symlink, the target file's bytes stream into MinIO, and the response of the asset-fetch endpoint returns those bytes verbatim. Result: a workspace-level builder reads any file the server process can open. This vulnerability is fixed in 3.39.9.

Weakness: CWE-59 (Improper Link Resolution Before File Access), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-54352?

2 open source packages ship an affected version, including @budibase/server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@budibase/server` | npm | All versions | 3.39.9 |
| `@budibase/server` | npm | All versions | 3.39.9 |

Products: Budibase Budibase.

## How do I fix CVE-2026-54352?

Upgrade @budibase/server to 3.39.9 or later.

## Is CVE-2026-54352 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54352 exists.

## Other vulnerabilities in budibase

- [CVE-2026-54350](https://insights.sbomify.com/CVE-2026-54350/): Budibase: Anonymous NoSQL operator injection via published-app query templates (critical 10.0)
- [CVE-2026-27702](https://insights.sbomify.com/CVE-2026-27702/): Budibase Vulnerable to Remote Code Execution via Unsafe eval() in View Filter Map Function (Budibase Cloud) (critical 9.9)
- [CVE-2026-31818](https://insights.sbomify.com/CVE-2026-31818/): Budibase: Server-Side Request Forgery via REST Connector with Empty Default Blacklist (critical 9.6)
- [CVE-2026-30240](https://insights.sbomify.com/CVE-2026-30240/): Budibase PWA ZIP Upload Path Traversal Allows Reading Arbitrary Server Files Including All Environment Secrets (critical 9.6)
- [CVE-2026-41428](https://insights.sbomify.com/CVE-2026-41428/): Budibase: Authentication Bypass via Unanchored Regex in Public Endpoint Matcher — Unauthenticated Access to Protected Endpoints (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54352 and fix it if it is affected.

What it is: CVE-2026-54352 is a critical path traversal vulnerability in budibase, published on 26 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-54352 exists.

Affected packages and fixed versions:
- @budibase/server (npm): affected all versions; fixed in 3.39.9
- @budibase/server (npm): affected all versions; fixed in 3.39.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54352/ (Markdown: https://insights.sbomify.com/CVE-2026-54352/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54352
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54352
- OSV: https://osv.dev/vulnerability/CVE-2026-54352

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54352/
Summaries are generated and may contain mistakes; the official description above is the record.
