# CVE-2026-54354: MapServer: PostGIS Numeric Filter Value SQL Injection in MapServer Runtime Query Translation

> Unauthenticated attackers can inject SQL via numeric filter inputs in MapServer PostGIS layers to read data or cause denial of service.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Sep 2026
- **Updated:** 18 Sep 2026
- **Also known as:** DEBIAN-CVE-2026-54354, GHSA-xp29-8wp5-wc3p, UBUNTU-CVE-2026-54354

## What is CVE-2026-54354?

CVE-2026-54354 is a high-severity SQL injection vulnerability in MapServer, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

MapServer is a system for developing web-based GIS applications. Prior to 8.6.4, MapServer's PostGIS runtime filter translation in src/mappostgis.cpp and msPostGISLayerTranslateFilter() treats a filteritem as numeric when CONNECTIONTYPE POSTGIS and metadata such as gml_<item>_type=Integer are configured, but it does not verify that attacker-controlled CGI qstring or OGC API Features featureId input is a numeric literal. The unquoted input is concatenated into the generated PostgreSQL/PostGIS predicate, allowing an unauthenticated remote attacker with access to an affected query endpoint to bypass predicates, enumerate unintended records, perform boolean-based or time-based SQL injection, and increase database load. The issue does not by itself establish database modification capabilities. This issue is fixed in version 8.6.4.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-54354?


## How do I fix CVE-2026-54354?

Upgrade to a fixed version.

## Is CVE-2026-54354 being exploited?

There is no known exploitation of CVE-2026-54354 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54354 and fix it if it is affected.

What it is: CVE-2026-54354 is a high-severity SQL injection vulnerability in MapServer, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-54354 in the wild and no public exploit code.

Affected product: MapServer. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54354/ (Markdown: https://insights.sbomify.com/CVE-2026-54354/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54354
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54354
- OSV: https://osv.dev/vulnerability/CVE-2026-54354

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54354/
Summaries are generated and may contain mistakes; the official description above is the record.
