# CVE-2026-54386: marimo < 0.23.9 XSS via file Query Parameter in assets.py

> Unauthenticated attackers can inject arbitrary JavaScript via a crafted link, enabling code execution in the victim's browser context.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Jun 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-8m59-7xv8-735h, PYSEC-2026-2619

## What is CVE-2026-54386?

CVE-2026-54386 is a medium-severity cross-site scripting vulnerability in marimo-team marimo, published on 17 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

marimo before 0.23.9 contains a reflected cross-site scripting vulnerability in the notebook page that allows unauthenticated attackers to inject arbitrary JavaScript by exploiting improper escaping of single quotes in the file query parameter reflected into an inline JavaScript string literal. Attackers can craft a malicious link with a payload beginning with __new__ to bypass the 404 check and inject JavaScript into the page, which executes without Content-Security-Policy restrictions in the origin of a victim's marimo server.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-54386?

3 open source packages ship an affected version, including marimo.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `marimo` | PyPI | All versions | 0.23.9 |
| `marimo` | PyPI | All versions | 0.23.9 |
| `marimo` | PyPI | All versions | 0.23.9 |

## How do I fix CVE-2026-54386?

Upgrade marimo to 0.23.9 or later.

## Is CVE-2026-54386 being exploited?

There is no known exploitation of CVE-2026-54386 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54386 and fix it if it is affected.

What it is: CVE-2026-54386 is a medium-severity cross-site scripting vulnerability in marimo-team marimo, published on 17 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-54386 in the wild and no public exploit code.

Affected packages and fixed versions:
- marimo (PyPI): affected all versions; fixed in 0.23.9
- marimo (PyPI): affected all versions; fixed in 0.23.9
- marimo (PyPI): affected all versions; fixed in 0.23.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54386/ (Markdown: https://insights.sbomify.com/CVE-2026-54386/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54386
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54386
- OSV: https://osv.dev/vulnerability/CVE-2026-54386

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54386/
Summaries are generated and may contain mistakes; the official description above is the record.
