# CVE-2026-54399: Apache HttpComponents Core: Unbounded HTTP Header/Line Length in Default Configuration

> Remote attackers can cause denial of service via memory exhaustion by sending excessive HTTP headers in Apache HttpComponents Core.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jul 2026
- **Updated:** 1 Jul 2026
- **Also known as:** CLEANSTART-2026-AE51081, CLEANSTART-2026-DM76657, CLEANSTART-2026-EL31068, CLEANSTART-2026-PR17240, CLEANSTART-2026-QY36065, CLSA-2026-1789467085, DEBIAN-CVE-2026-54399, ECHO-b453-6acb-8261, GHSA-hf6x-8p5f-cgmf, MINI-28h5-xpg9-c58j, MINI-2pcg-7hx7-hm8q, MINI-2qxw-5f2f-43v7, MINI-2x3j-w372-q539, MINI-3qc2-pmwv-wjww, MINI-3rqr-g9gv-c65f, MINI-43f6-xjhm-6v86, MINI-47w3-59p8-vc2x, MINI-4gwv-r9jv-8xj2, MINI-4j84-php4-6hc9, MINI-4jg5-h249-qw37, MINI-5pfr-cjmp-cg45, MINI-6223-6qh8-jv6h, MINI-64cv-h2hh-3x4g, MINI-6g8c-5h7v-c8g8, MINI-6jrm-vmph-4fwj, MINI-7chp-q8qf-m7m5, MINI-927w-9p26-h3jh, MINI-9h7m-gv65-xcxh, MINI-chx8-4c3g-qw2c, MINI-fqjx-ggpv-7vxh, MINI-frc3-9cg9-3rqq, MINI-gqxh-gxhm-6w24, MINI-hm7r-2gwm-66w8, MINI-m53p-43jv-x93r, MINI-m656-57hp-w485, MINI-mgj5-9rfv-g8gp, MINI-mv96-hjhc-5xjc, MINI-pqjh-j9qc-99h8, MINI-qqpm-hhrx-6hx3, MINI-r5q8-4xfg-gmcw, MINI-v5f4-rhjm-46m8, MINI-vjm3-4v75-v23v, MINI-x2pv-qpm2-4c8j, MINI-xg3w-p38f-xj5h, ROOT-APP-MAVEN-CVE-2026-54399, UBUNTU-CVE-2026-54399

## What is CVE-2026-54399?

CVE-2026-54399 is a high-severity denial of service vulnerability in Apache HttpComponents Core, published on 1 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Uncontrolled Resource Consumption vulnerability in the HTTP/1.1 message parser in Apache HttpComponents Core (5.4.2 and earlier, 5.5-beta1 and earlier) allows an remote attacker to cause a denial of service through memory exhaustion by sending messages with excessive number of headers / excessive header length

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-54399?

4 open source packages ship an affected version, including org.apache.httpcomponents.core5:httpcore5. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.httpcomponents.core5:httpcore5` | Maven | All versions | 5.4.3 |
| `org.apache.httpcomponents.core5:httpcore5` | Maven | All versions | 5.4.3 |
| `org.apache.httpcomponents.core5:httpcore5` | Maven | From 5.5-alpha1 | 5.5-beta2 |
| `org.apache.httpcomponents.core5:httpcore5` | Maven | From 5.5-alpha1 | 5.5-beta2 |

Products: Apache Httpcomponents Core.

## How do I fix CVE-2026-54399?

Upgrade org.apache.httpcomponents.core5:httpcore5 to a fixed version for your release line: 5.4.3 or 5.5-beta2.

## Is CVE-2026-54399 being exploited?

There is no known exploitation of CVE-2026-54399 in the wild and no public exploit code.

## Other vulnerabilities in Apache HttpComponents Core

- [CVE-2026-54428](https://insights.sbomify.com/CVE-2026-54428/): Apache HttpComponents Core: HPackDecoder Unlimited Header List Size Before SETTINGS ACK (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-54399 and fix it if it is affected.

What it is: CVE-2026-54399 is a high-severity denial of service vulnerability in Apache HttpComponents Core, published on 1 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-54399 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.httpcomponents.core5:httpcore5 (Maven): affected all versions; fixed in 5.4.3
- org.apache.httpcomponents.core5:httpcore5 (Maven): affected all versions; fixed in 5.4.3
- org.apache.httpcomponents.core5:httpcore5 (Maven): affected from 5.5-alpha1; fixed in 5.5-beta2
- org.apache.httpcomponents.core5:httpcore5 (Maven): affected from 5.5-alpha1; fixed in 5.5-beta2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-54399/ (Markdown: https://insights.sbomify.com/CVE-2026-54399/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-54399
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-54399
- OSV: https://osv.dev/vulnerability/CVE-2026-54399

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-54399/
Summaries are generated and may contain mistakes; the official description above is the record.
